summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns/ChangeLog7
-rw-r--r--net-dns/pdns/Manifest6
-rw-r--r--net-dns/pdns/files/digest-pdns-2.9.12-r11
-rw-r--r--net-dns/pdns/pdns-2.9.12-r1.ebuild44
-rw-r--r--net-dns/pdns/pdns-2.9.12.ebuild4
5 files changed, 56 insertions, 6 deletions
diff --git a/net-dns/pdns/ChangeLog b/net-dns/pdns/ChangeLog
index dd8a7e25edb6..fb6143b42e16 100644
--- a/net-dns/pdns/ChangeLog
+++ b/net-dns/pdns/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for net-dns/pdns
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.3 2003/10/30 15:20:07 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.4 2003/12/14 18:48:46 jhhudso Exp $
+*pdns-2.9.12-r1 (14 Dec 2003)
+
+ 14 Dec 2003; Jared Hudson <jhhudso@gentoo.org> : Postgresql support added
+ via use variable thanks to Rafal Rzepecki <divide@poczta.onet.pl>
+
*pdns-2.9.12 (30 Oct 2003)
30 Oct 2003; Jared Hudson <jhhudso@gentoo.org> : Version bump.
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index a70a3e61952c..5c5c2f7ee9a7 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,8 +1,8 @@
-MD5 ae225850df4e22ef0d85c5dda567edb3 pdns-2.9.12.ebuild 971
+MD5 3a56cd13f5a5e84eae66590b77e472c6 pdns-2.9.12.ebuild 970
MD5 820d957f19bc40f0cef9722ff9dfb986 pdns-2.9.8.ebuild 970
MD5 f71c33d3646cab7f4e79b40dafba3737 metadata.xml 251
-MD5 623d3ef939334ccfb77255982b3fb8f2 ChangeLog 594
-MD5 d1ae1072d2cb61af17162c4337492fca pdns-2.9.12-r1.ebuild 1133
+MD5 5a5405eac4ec5535b2a811d3baabed86 ChangeLog 771
+MD5 ed8b77d36f9eab478640b9744af07f77 pdns-2.9.12-r1.ebuild 1136
MD5 0969ab0b2776f09c9aeb74b0996c4426 files/pdns 533
MD5 0dfd77947e929c57e09b695e6c9aa4a5 files/digest-pdns-2.9.12-r1 63
MD5 0dfd77947e929c57e09b695e6c9aa4a5 files/digest-pdns-2.9.12 63
diff --git a/net-dns/pdns/files/digest-pdns-2.9.12-r1 b/net-dns/pdns/files/digest-pdns-2.9.12-r1
new file mode 100644
index 000000000000..64e4a44309ca
--- /dev/null
+++ b/net-dns/pdns/files/digest-pdns-2.9.12-r1
@@ -0,0 +1 @@
+MD5 c30c664b7f1c3baad4422e99c9dd1f18 pdns-2.9.12.tar.gz 719406
diff --git a/net-dns/pdns/pdns-2.9.12-r1.ebuild b/net-dns/pdns/pdns-2.9.12-r1.ebuild
new file mode 100644
index 000000000000..10790f3ac2b8
--- /dev/null
+++ b/net-dns/pdns/pdns-2.9.12-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.12-r1.ebuild,v 1.1 2003/12/14 18:48:46 jhhudso Exp $
+
+DESCRIPTION="The PowerDNS Daemon."
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
+HOMEPAGE="http://www.powerdns.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mysql postgres static"
+
+DEPEND="virtual/glibc
+ mysql? ( >=dev-db/mysql-3.23.54a )
+ postgres? ( >=dev-libs/libpq++-4.0-r1 )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf=""
+ local modules=""
+
+ use static && myconf="$myconf --enable-static-binaries"
+ use mysql && modules="gmysql $modules"
+ use postgres && modules="gpgsql $modules"
+ use postgres && myconf="$myconf --with-pgsql-includes=/usr/include"
+ myconf="$myconf --with-modules=$modules"
+
+ econf $myconf
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog HACKING INSTALL README TODO WARNING pdns/COPYING
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/pdns
+
+ mv ${D}/etc/pdns.conf-dist ${D}/etc/pdns.conf
+}
diff --git a/net-dns/pdns/pdns-2.9.12.ebuild b/net-dns/pdns/pdns-2.9.12.ebuild
index 97146d9242fc..a80245f63fe7 100644
--- a/net-dns/pdns/pdns-2.9.12.ebuild
+++ b/net-dns/pdns/pdns-2.9.12.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.12.ebuild,v 1.2 2003/10/30 15:25:02 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.12.ebuild,v 1.3 2003/12/14 18:48:46 jhhudso Exp $
DESCRIPTION="The PowerDNS Daemon."
SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
HOMEPAGE="http://www.powerdns.com/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE="mysql static"
DEPEND="virtual/glibc