summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/am-utils/am-utils-6.0.9-r1.ebuild')
-rw-r--r--net-fs/am-utils/am-utils-6.0.9-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-fs/am-utils/am-utils-6.0.9-r1.ebuild b/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
new file mode 100644
index 000000000000..24110ea712d0
--- /dev/null
+++ b/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9-r1.ebuild,v 1.1 2003/10/16 15:54:15 drobbins Exp $
+
+IUSE="ldap"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="amd automounter and utilities"
+HOMEPAGE="http://www.am-utils.org"
+SRC_URI="ftp://ftp.am-utils.org/pub/am-utils/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ ldap? ( >=net-nds/openldap-1.2 )"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 amd64"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat ${FILESDIR}/am-utils-gdbm.patch | patch -p1 || die
+}
+
+src_compile() {
+ local myconf
+
+ use ldap \
+ && myconf="${myconf} --without-ldap" \
+ || myconf="${myconf} --with-ldap"
+
+ myconf="${myconf} --sysconfdir=/etc/amd"
+
+ cd ${S}
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ cp ${FILESDIR}/amd.conf ${D}/etc/amd
+ cp ${FILESDIR}/amd.net ${D}/etc/amd
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/amd.rc amd
+}