summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/ncpfs/ncpfs-2.2.5.ebuild')
-rw-r--r--net-fs/ncpfs/ncpfs-2.2.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-fs/ncpfs/ncpfs-2.2.5.ebuild b/net-fs/ncpfs/ncpfs-2.2.5.ebuild
new file mode 100644
index 000000000000..ab6557af1601
--- /dev/null
+++ b/net-fs/ncpfs/ncpfs-2.2.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.5.ebuild,v 1.1 2004/12/01 21:28:57 griffon26 Exp $
+
+inherit eutils
+
+IUSE="nls pam"
+
+DESCRIPTION="Provides Access to Netware services using the NCP protocol (Kernel support must be activated!)"
+SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/${PN}/${P}.tar.gz"
+HOMEPAGE="ftp://platan.vc.cvut.cz/pub/linux/ncpfs/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~ppc64"
+
+DEPEND="nls? ( sys-devel/gettext )
+ pam? ( sys-libs/pam )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Needed because the directory in the tar.gz is not readable for anyone
+ chmod a+r ${S}
+}
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ myconf="${myconf} `use_enable pam`"
+
+ econf ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install () {
+ # directory ${D}/lib/security needs to be created or the install fails
+ dodir /lib/security
+ dodir /usr/sbin
+ dodir /sbin
+ make DESTDIR=${D} install || die
+
+ dodoc FAQ README
+}