summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/ftpcube/ftpcube-0.3.3.ebuild')
-rw-r--r--net-ftp/ftpcube/ftpcube-0.3.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-ftp/ftpcube/ftpcube-0.3.3.ebuild b/net-ftp/ftpcube/ftpcube-0.3.3.ebuild
new file mode 100644
index 000000000000..2f9bbd455a48
--- /dev/null
+++ b/net-ftp/ftpcube/ftpcube-0.3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ftpcube-0.3.3.ebuild,v 1.1 2002/08/20 01:33:34 bass Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Graphic ftp client written in python and gtk"
+SRC_URI="mirror://sourceforge/ftpcube/${P}.tar.gz"
+HOMEPAGE="ftpcube.sf.net"
+DEPEND="<dev-python/pygtk-1.99.0"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="x86 sparc sparc64"
+
+src_compile() {
+ python setup.py clean || die "clean fails"
+}
+
+src_install() {
+ dobin ftpcube
+ dodir /usr/lib/python2.2/site-packages/libftpcube
+ insinto /usr/lib/python2.2/site-packages/libftpcube
+ doins libftpcube/*
+ dodir /usr/share/ftpcube/icons
+ insinto /usr/share/ftpcube/icons
+ doins icons/*
+ dosym /usr/share/ftpcube/icons/ftpcube.xpm /usr/share/icons
+ dodoc CHANGELOG README
+}