summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/vyqchat/vyqchat-0.1.1.ebuild')
-rw-r--r--net-irc/vyqchat/vyqchat-0.1.1.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/net-irc/vyqchat/vyqchat-0.1.1.ebuild b/net-irc/vyqchat/vyqchat-0.1.1.ebuild
index 91005073d329..b4dfd9e26520 100644
--- a/net-irc/vyqchat/vyqchat-0.1.1.ebuild
+++ b/net-irc/vyqchat/vyqchat-0.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/vyqchat/vyqchat-0.1.1.ebuild,v 1.6 2004/06/24 23:09:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/vyqchat/vyqchat-0.1.1.ebuild,v 1.7 2004/07/24 01:14:16 swegener Exp $
DESCRIPTION="QT based Vypress Chat clone for X."
HOMEPAGE="http://linux.bydg.org/~yogin/"
@@ -12,19 +12,18 @@ KEYWORDS="x86"
IUSE="arts"
DEPEND=">=x11-libs/qt-3.0
- arts? ( kde-base/arts )"
+ arts? ( kde-base/arts )"
src_compile() {
- local myconf
- use arts && myconf="--with-arts"
- ./configure --host=${CHOST} \
- --prefix=/usr --infodir=/usr/share/info \
- --mandir=/usr/share/man --with-x \
- --with-Qt-dir=/usr/qt/3 ${myconf} || die "./configure failed"
- emake || die
+ econf \
+ --with-x \
+ --with-Qt-dir=/usr/qt/3 \
+ $(use_with arts) \
+ || die "econf failed"
+ emake || die "emake failed"
}
src_install() {
- einstall || die
- dodoc README THANKS NEWS
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc README THANKS NEWS || die "dodoc failed"
}