summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/vyqchat/vyqchat-0.2.6.ebuild')
-rw-r--r--net-irc/vyqchat/vyqchat-0.2.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-irc/vyqchat/vyqchat-0.2.6.ebuild b/net-irc/vyqchat/vyqchat-0.2.6.ebuild
new file mode 100644
index 000000000000..9fda67fb8e94
--- /dev/null
+++ b/net-irc/vyqchat/vyqchat-0.2.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/vyqchat/vyqchat-0.2.6.ebuild,v 1.1 2004/07/24 01:14:16 swegener Exp $
+
+DESCRIPTION="QT based Vypress Chat clone for X."
+HOMEPAGE="http://linux.bydg.org/~yogin/"
+SRC_URI="http://linux.bydg.org/~yogin/${P}.tar.gz
+ http://linux.bydg.org/~yogin/${P}-fix.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="arts"
+
+DEPEND=">=x11-libs/qt-3.0
+ arts? ( kde-base/arts )"
+
+src_unpack() {
+ unpack ${A}
+
+ mv -f ${WORKDIR}/${PN}/* ${S}
+}
+
+src_compile() {
+ econf \
+ --with-x \
+ --with-Qt-dir=/usr/qt/3 \
+ $(use_with arts) \
+ || die "econf failed"
+ make || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc README THANKS NEWS || die "dodoc failed"
+}