summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/weechat/weechat-0.3.4.ebuild')
-rw-r--r--net-irc/weechat/weechat-0.3.4.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-irc/weechat/weechat-0.3.4.ebuild b/net-irc/weechat/weechat-0.3.4.ebuild
index 0ecada888444..06c0a6a4d9cf 100644
--- a/net-irc/weechat/weechat-0.3.4.ebuild
+++ b/net-irc/weechat/weechat-0.3.4.ebuild
@@ -1,14 +1,17 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.3.4.ebuild,v 1.4 2011/04/26 14:49:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.3.4.ebuild,v 1.5 2011/04/28 10:50:07 scarabeus Exp $
EAPI=3
+USE_RUBY="ruby18 ruby19"
+RUBY_OPTIONAL="yes"
+
PYTHON_DEPEND="python? 2"
EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
[[ ${PV} == "9999" ]] && GIT_ECLASS="git"
-inherit python multilib cmake-utils ${GIT_ECLASS}
+inherit python multilib ruby-ng cmake-utils ${GIT_ECLASS}
DESCRIPTION="Portable and multi-interface IRC client."
HOMEPAGE="http://weechat.org/"
@@ -33,7 +36,6 @@ RDEPEND="
lua? ( dev-lang/lua[deprecated] )
ncurses? ( sys-libs/ncurses )
perl? ( dev-lang/perl )
- ruby? ( dev-lang/ruby )
ssl? ( net-libs/gnutls )
spell? ( app-text/aspell )
tcl? ( >=dev-lang/tcl-8.4.15 )
@@ -49,6 +51,8 @@ DOCS="AUTHORS ChangeLog NEWS README"
pkg_setup() {
python_set_active_version 2
+
+ ruby-ng_pkg_setup
}
src_prepare() {