summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog7
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.2.5-sparc64-build.patch23
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.2.5-r200.ebuild6
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.2.5.ebuild6
4 files changed, 39 insertions, 3 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index ed0817fad3b4..17c84b29f5a3 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.250 2014/03/08 08:49:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.251 2014/03/08 09:22:29 pacho Exp $
+
+ 08 Mar 2014; Pacho Ramos <pacho@gentoo.org>
+ +files/webkit-gtk-2.2.5-sparc64-build.patch, webkit-gtk-2.2.5-r200.ebuild,
+ webkit-gtk-2.2.5.ebuild:
+ Apply openBSD patch for compat with sparc64
08 Mar 2014; Pacho Ramos <pacho@gentoo.org> webkit-gtk-2.2.5-r200.ebuild,
webkit-gtk-2.2.5.ebuild:
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.2.5-sparc64-build.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.2.5-sparc64-build.patch
new file mode 100644
index 000000000000..691b52862ec2
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.2.5-sparc64-build.patch
@@ -0,0 +1,23 @@
+$OpenBSD: patch-Source_WTF_wtf_Atomics_h,v 1.3 2013/10/20 09:07:57 landry Exp $
+
+https://bugs.webkit.org/show_bug.cgi?id=86835
+Fix build failure on sparc64 since 1.8.1, provide atomic{In,De}crement implems based on __sync_fetch_and_add builtin
+
+--- Source/WTF/wtf/Atomics.h.orig Sat Aug 3 18:10:38 2013
++++ Source/WTF/wtf/Atomics.h Sun Oct 20 11:06:14 2013
+@@ -112,6 +112,15 @@ inline int atomicDecrement(int volatile* addend) { ret
+ inline int64_t atomicIncrement(int64_t volatile* addend) { return __sync_add_and_fetch(addend, 1); }
+ inline int64_t atomicDecrement(int64_t volatile* addend) { return __sync_sub_and_fetch(addend, 1); }
+
++#elif COMPILER(GCC) && CPU(SPARC64)
++#define WTF_USE_LOCKFREE_THREADSAFEREFCOUNTED 1
++
++inline int atomicIncrement(int volatile* addend) { return __sync_fetch_and_add(addend, 1) + 1; }
++inline int atomicDecrement(int volatile* addend) { return __sync_fetch_and_add(addend, -1) - 1; }
++
++inline int64_t atomicIncrement(int64_t volatile* addend) { return __sync_fetch_and_add(addend, 1) + 1; }
++inline int64_t atomicDecrement(int64_t volatile* addend) { return __sync_fetch_and_add(addend, -1) - 1; }
++
+ #endif
+
+ #if OS(WINDOWS)
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.2.5-r200.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.2.5-r200.ebuild
index 97ba3052c38b..61a965e78d5f 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.2.5-r200.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.2.5-r200.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.2.5-r200.ebuild,v 1.6 2014/03/08 08:49:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.2.5-r200.ebuild,v 1.7 2014/03/08 09:22:29 pacho Exp $
EAPI="5"
@@ -178,6 +178,10 @@ src_prepare() {
# https://bugs.webkit.org/show_bug.cgi?id=129542
epatch "${FILESDIR}"/${PN}-2.2.5-ia64-malloc.patch
+ # OpenBSD patches to fix support for some arches
+ # https://bugs.webkit.org/show_bug.cgi?id=86835
+ epatch "${FILESDIR}"/${PN}-2.2.5-sparc64-build.patch
+
# Prevent maintainer mode from being triggered during make
AT_M4DIR=Source/autotools eautoreconf
}
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.2.5.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.2.5.ebuild
index 28bb7d5f9b91..100c6a584542 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.2.5.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.2.5.ebuild,v 1.6 2014/03/08 08:49:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.2.5.ebuild,v 1.7 2014/03/08 09:22:29 pacho Exp $
EAPI="5"
@@ -183,6 +183,10 @@ src_prepare() {
# https://bugs.webkit.org/show_bug.cgi?id=129542
epatch "${FILESDIR}"/${PN}-2.2.5-ia64-malloc.patch
+ # OpenBSD patches to fix support for some arches
+ # https://bugs.webkit.org/show_bug.cgi?id=86835
+ epatch "${FILESDIR}"/${PN}-2.2.5-sparc64-build.patch
+
# Prevent maintainer mode from being triggered during make
AT_M4DIR=Source/autotools eautoreconf
}