summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/dovecot')
-rw-r--r--net-mail/dovecot/ChangeLog9
-rw-r--r--net-mail/dovecot/dovecot-1.0_beta9-r1.ebuild178
-rw-r--r--net-mail/dovecot/files/digest-dovecot-1.0_beta9-r13
-rw-r--r--net-mail/dovecot/files/dovecot-1.0_beta9-configure.patch191
4 files changed, 380 insertions, 1 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index 8c9b05a8da58..11e19eea9cf2 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/dovecot
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.53 2006/06/15 08:50:41 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.54 2006/06/16 08:42:06 uberlord Exp $
+
+*dovecot-1.0_beta9-r1 (16 Jun 2006)
+
+ 16 Jun 2006; Roy Marples <uberlord@gentoo.org>
+ +files/dovecot-1.0_beta9-configure.patch, +dovecot-1.0_beta9-r1.ebuild:
+ Patch configure.in to detect working inotify, epoll, kqueue, dnotify as
+ we cannot do so in the ebuild.
15 Jun 2006; Roy Marples <uberlord@gentoo.org>
dovecot-1.0_beta8-r1.ebuild, dovecot-1.0_beta9.ebuild:
diff --git a/net-mail/dovecot/dovecot-1.0_beta9-r1.ebuild b/net-mail/dovecot/dovecot-1.0_beta9-r1.ebuild
new file mode 100644
index 000000000000..825e132e6083
--- /dev/null
+++ b/net-mail/dovecot/dovecot-1.0_beta9-r1.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0_beta9-r1.ebuild,v 1.1 2006/06/16 08:42:06 uberlord Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
+HOMEPAGE="http://dovecot.org/"
+MY_P="${P/_/.}"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://dovecot.org/releases/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+IUSE="debug doc ipv6 kerberos ldap mbox mysql pop3d pam postgres ssl vpopmail"
+
+DEPEND=">=sys-apps/sed-4
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ postgres? ( dev-db/postgresql )
+ mysql? ( dev-db/mysql )
+ vpopmail? ( net-mail/vpopmail )"
+
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00-r8"
+
+pkg_setup() {
+ # Add user and group for login process (same as for fedora/redhat)
+ enewgroup dovecot 97
+ enewuser dovecot 97 -1 /dev/null dovecot
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}"-configure.patch
+ eautoconf
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+ use ssl && myconf="${myconf} --with-ssl=openssl" \
+ || myconf="${myconf} --without-ssl"
+
+ econf --localstatedir=/var \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with kerberos gssapi) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with pam) \
+ $(use_with pop3d) \
+ $(use_with postgres pgsql) \
+ $(use_with vpopmail) \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ newinitd "${FILESDIR}"/dovecot.init dovecot
+
+ # Create the dovecot.conf file from the dovecot-example.conf file that
+ # the dovecot folks nicely left for us....
+ mv "${D}"/etc/dovecot-example.conf "${D}"/etc/dovecot.conf
+ fperms 0600 /etc/dovecot.conf
+
+ # .maildir is the Gentoo default, but we need to support mbox to
+ local mailenv="maildir:%h/.maildir"
+ if use mbox ; then
+ mailenv="mbox:/var/spool/mail/%u:INDEX=/var/dovecot/%u"
+ keepdir /var/dovecot
+ sed -i -e 's|#mail_extra_groups =|mail_extra_groups = mail|' \
+ "${D}"/etc/dovecot.conf
+ fi
+ sed -i -e \
+ "s|#default_mail_env =|default_mail_env = ${mailenv}|" \
+ "${D}"/etc/dovecot.conf
+
+ # We're using pam files (imap and pop3) provided by mailbase
+ if use pam ; then
+ sed -i -e '/passdb pam/, /^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
+ "${D}"/etc/dovecot.conf
+ fi
+
+ # Listen on ipv6 and ipv4
+ if use ipv6 ; then
+ sed -i -e 's/^#listen = \*/listen = \[::\]/g' \
+ "${D}"/etc/dovecot.conf
+ else
+ # BETA9 FIX ONLY - REMOVE IF NOT BETA9
+ # Beta9 has issues when compiled without ipv6
+ # setting ssl_listen = * fixes the issue
+ sed -i -e 's/^#ssl_listen =/ssl_listen = */g' \
+ "${D}"/etc/dovecot.conf
+ fi
+
+ # Install SQL configuration
+ if use mysql || use postgres ; then
+ cp doc/dovecot-sql.conf "${D}"/etc
+ fperms 600 /etc/dovecot-sql.conf
+ sed -i -e '/db sql/,/args/ s|=|= /etc/dovecot-sql.conf|' \
+ "${D}"/etc/dovecot.conf
+ fi
+
+ # Install LDAP configuration
+ if use ldap ; then
+ cp doc/dovecot-ldap.conf "${D}"/etc
+ fperms 600 /etc/dovecot-ldap.conf
+ sed -i -e '/db ldap/,/args/ s|=|= /etc/dovecot-ldap.conf|' \
+ "${D}"/etc/dovecot.conf
+ fi
+
+ # Documentation
+ rm -rf "${D}"/usr/share/doc/dovecot
+ if use doc ; then
+ dodoc AUTHORS NEWS README TODO dovecot-example.conf
+ dodoc doc/*.txt doc/*.conf doc/*.cnf doc/mkcert.sh
+ fi
+
+ # Create SSL certificates
+ if use ssl ; then
+ dodir /etc/ssl/certs
+ dodir /etc/ssl/private
+ # Let's not make a new certificate if we already have one
+ if ! [[ -e /etc/ssl/certs/dovecot.pem && \
+ -e /etc/ssl/private/dovecot.pem ]]; then
+ einfo "Generating X.509 certificate for SSL"
+ pushd doc >/dev/null && \
+ SSLDIR="${D}"/etc/ssl sh mkcert.sh && \
+ popd >/dev/null
+ fi
+ fi
+
+ dodir /var/run/dovecot
+ fowners root:0 /var/run/dovecot
+ fperms 0700 /var/run/dovecot
+ keepdir /var/run/dovecot/login
+ fowners root:dovecot /var/run/dovecot/login
+ fperms 0750 /var/run/dovecot/login
+}
+
+get_config_var() {
+ sed -n 's/^[[:space:]]\?base_dir[[:space:]]*="*\([^#"]\+\)"*/\1/p' \
+ /etc/dovecot.conf
+}
+
+pkg_postinst() {
+ einfo "The dovecot configuration has vastly changed since 0.99."
+ einfo "You are encouraged to start afresh with a new configuration file."
+ einfo "see http://wiki.dovecot.org/ for configuration examples."
+
+ local base_dir="$(get_config_var base_dir)"
+ base_dir="${basedir:-/var/run/dovecot}"
+ if [[ ! -e "${ROOT}/${base_dir}/login/ssl-parameters.dat" ]] ; then
+ einfo
+ einfo "Dovecot requires DH SSL Parameters if you use SSL connections"
+ einfo "These take some time to make, and dovecot will create them before"
+ einfo "it allows any SSL connections."
+ einfo "You can create them now before starting dovecot like so"
+ einfo " emerge --config =${PF}"
+ fi
+}
+
+pkg_config() {
+ local base_dir="$(get_config_var base_dir)"
+ base_dir="${base_dir:-/var/run/dovecot}"
+
+ einfo "Regenerating SSL parameters. This will take some time."
+ /usr/libexec/dovecot/ssl-build-param "${base_dir}/login/ssl-parameters.dat"
+}
diff --git a/net-mail/dovecot/files/digest-dovecot-1.0_beta9-r1 b/net-mail/dovecot/files/digest-dovecot-1.0_beta9-r1
new file mode 100644
index 000000000000..5e22728901a3
--- /dev/null
+++ b/net-mail/dovecot/files/digest-dovecot-1.0_beta9-r1
@@ -0,0 +1,3 @@
+MD5 5c19a21afb8a02c95f3f62fa37d8e1ed dovecot-1.0.beta9.tar.gz 1245601
+RMD160 30d423b9fd2056fd8d898bc4bc630d3806cc64c4 dovecot-1.0.beta9.tar.gz 1245601
+SHA256 1bc44e2ab23ac8863aea42ce4ea5045d5f6ee2375804e432d8e7f918c14379b8 dovecot-1.0.beta9.tar.gz 1245601
diff --git a/net-mail/dovecot/files/dovecot-1.0_beta9-configure.patch b/net-mail/dovecot/files/dovecot-1.0_beta9-configure.patch
new file mode 100644
index 000000000000..02b4f7a43502
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-1.0_beta9-configure.patch
@@ -0,0 +1,191 @@
+Add detection for working epoll, inotify, kqueue, dnotify and poll.
+This should solve the issue of inotify.h being present but the kernel
+and/or glibc does not support it.
+
+--- configure.in 2006-06-13 12:24:58.000000000 +0100
++++ configure.in 2006-06-15 14:46:05.620287008 +0100
+@@ -364,29 +364,39 @@
+ dnl * I/O loop function
+ have_ioloop=no
+
+-dnl we currently don't use epoll automatically because it fails at runtime
+-dnl if we're not running 2.6 kernel
+-if test "$ioloop" = "epoll"; then
+- AC_CHECK_FUNC(epoll_create, [
++if test "$ioloop" = "" || test "$ioloop" = "epoll"; then
++ AC_TRY_RUN([
++ #include <stdint.h>
++ #include <sys/epoll.h>
++ #include <errno.h>
++
++ #include <asm/unistd.h>
++
++ _syscall1 (int, epoll_create, int, size)
++
++ int main()
++ {
++ return epoll_create(5) < 1;
++ }
++ ], [
+ AC_DEFINE(IOLOOP_EPOLL,, Implement I/O loop with Linux 2.6 epoll())
+ have_ioloop=yes
++ ioloop=epoll
+ ], [
+- ioloop=""
++ if test "$ioloop" != "" ; then
++ AC_MSG_WARN([epoll ioloop requested but epoll_create() is not available])
++ fi
+ ])
+ fi
+
+-if test "$ioloop" = "kqueue"; then
+- if test "$ac_cv_func_kqueue" != yes ; then
+- AC_MSG_WARN([kqueue ioloop requested but kqueue() is not available])
+- ioloop=""
+- elif test "$ac_cv_func_kevent" != yes ; then
+- AC_MSG_WARN([kqueue ioloop requested but kevent() is not available])
+- ioloop=""
+- else
+- AC_DEFINE(IOLOOP_KQUEUE,, [Implement I/O loop with BSD kqueue()])
+- ioloop=kqueue
+- have_ioloop=yes
+- fi
++if test "$ioloop" = "" || test "$ioloop" = "kqueue"; then
++ if test "$ac_cv_func_kqueue" = yes && test "$ac_cv_func_kevent" == yes ; then
++ AC_DEFINE(IOLOOP_KQUEUE,, [Implement I/O loop with BSD kqueue()])
++ ioloop=kqueue
++ have_ioloop=yes
++ elif test "$ioloop" = "kqueue"; then
++ AC_MSG_WARN([kqueue ioloop requested but kqueue() is not available])
++ fi
+ fi
+
+ if test "$ioloop" = "" || test "$ioloop" = "poll"; then
+@@ -404,69 +414,83 @@
+
+ have_notify=none
+
+-if test "$notify" = "" || test "$notify" = "dnotify"; then
+- dnl * dnotify?
+- AC_TRY_COMPILE([
+- #define _GNU_SOURCE
+- #include <fcntl.h>
+- #include <signal.h>
+- #include <unistd.h>
+- ], [
+- fcntl(0, F_SETSIG, SIGRTMIN);
+- fcntl(0, F_NOTIFY, DN_CREATE | DN_DELETE | DN_RENAME | DN_MULTISHOT);
+- ], [
+- AC_DEFINE(IOLOOP_NOTIFY_DNOTIFY,, Use Linux dnotify)
+- have_notify=dnotify
+- ], [
+- if test "$notify" = "dnotify"; then
+- AC_MSG_ERROR([dnotify requested but not available])
+- fi
+- ])
+-elif test "$notify" = "inotify"; then
++if test "$notify" = "" || test "$notify" = "inotify" ; then
+ dnl * inotify?
+- AC_TRY_COMPILE([
++ AC_TRY_RUN([
+ #define _GNU_SOURCE
+ #include <sys/ioctl.h>
+ #include <fcntl.h>
+ #include <sys/inotify.h>
+ #include <stdio.h>
+- ], [
+- int wd, fd;
+- char * fn = "/tmp";
++
++ int main()
++ {
++ int wd, fd;
++ char * fn = "/tmp";
+
+- fd = inotify_init ();
+- if (fd < 0)
+- perror ("inotify_init");
+-
+- wd = inotify_add_watch (fd, fn, IN_ALL_EVENTS);
++ fd = inotify_init ();
++ if (fd < 0)
++ {
++ perror ("inotify_init");
++ return (-1);
++ }
++
++ wd = inotify_add_watch (fd, fn, IN_ALL_EVENTS);
++
++ if (wd < 0)
++ {
++ perror ("inotify_add_watch");
++ return (-2);
++ }
+
+- if (wd < 0)
+- perror ("inotify_add_watch");
++ inotify_rm_watch (fd, wd);
+
+- inotify_rm_watch (fd, wd);
+-
+- close (fd);
++ close (fd);
++ }
+ ], [
+ have_notify=inotify
++ notify=inotify
+ AC_DEFINE(IOLOOP_NOTIFY_INOTIFY,, Use Linux inotify)
+ ], [
+- AC_MSG_ERROR([inotify requested but not available, check for existence of <sys/inotify.h>])
++ if test "$notify" = "inotify"; then
++ AC_MSG_WARN([inotify requested but not available])
++ fi
+ ])
+-elif test "$notify" = "kqueue"; then
++fi
++
++if test "$notify" = "" || test "$notify" = "kqueue"; then
+ dnl * BSD kqueue() notify
+- if test "$ac_cv_func_kqueue" != yes ; then
+- AC_MSG_WARN([kqueue notify requested but kqueue() is not available])
+- notify=""
+- elif test "$ac_cv_func_kevent" != yes ; then
+- AC_MSG_WARN([kqueue notify requested but kevent() is not available])
+- notify=""
+- else
++ if test "$ac_cv_func_kqueue" == yes && test "$ac_cv_func_kevent" == yes ; then
+ have_notify=kqueue
++ notify=kqueue
+ AC_DEFINE(IOLOOP_NOTIFY_KQUEUE,,
+ Use BSD kqueue directory changes notificaton)
++ else
++ if test "$notfify" = "kqueue" ; then
++ AC_MSG_WARN([kqueue notify requested but kqueue() is not available])
++ fi
+ fi
+-else
+- AC_MSG_ERROR([Unknown notify method: $notify])
++fi
++
++if test "$notify" = "" || test "$notify" = "dnotify"; then
++ dnl * dnotify?
++ AC_TRY_COMPILE([
++ #define _GNU_SOURCE
++ #include <fcntl.h>
++ #include <signal.h>
++ #include <unistd.h>
++ ], [
++ fcntl(0, F_SETSIG, SIGRTMIN);
++ fcntl(0, F_NOTIFY, DN_CREATE | DN_DELETE | DN_RENAME | DN_MULTISHOT);
++ ], [
++ AC_DEFINE(IOLOOP_NOTIFY_DNOTIFY,, Use Linux dnotify)
++ have_notify=dnotify
++ notify=dnotify
++ ], [
++ if test "$notify" = "dnotify"; then
++ AC_MSG_WARN([dnotify requested but not available])
++ fi
++ ])
+ fi
+
+ if test "$have_notify" = "none"; then