summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/libdbx/libdbx-1.0.3.ebuild')
-rw-r--r--net-mail/libdbx/libdbx-1.0.3.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-mail/libdbx/libdbx-1.0.3.ebuild b/net-mail/libdbx/libdbx-1.0.3.ebuild
index 280a49befd27..79781417d9bf 100644
--- a/net-mail/libdbx/libdbx-1.0.3.ebuild
+++ b/net-mail/libdbx/libdbx-1.0.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libdbx/libdbx-1.0.3.ebuild,v 1.6 2013/03/23 17:08:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libdbx/libdbx-1.0.3.ebuild,v 1.7 2013/06/21 13:55:04 jer Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Tools and library for reading Outlook Express mailboxes (.dbx format)"
HOMEPAGE="http://sourceforge.net/projects/ol2mbox"
@@ -26,10 +26,11 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/bad_c.patch"
- sed -i -e 's/-g/$(CFLAGS) $(LDFLAGS)/' Makefile
+ sed -i -e 's/-g/$(CFLAGS) $(LDFLAGS)/;s|gcc|$(CC)|g' Makefile
}
src_compile() {
+ tc-export CC
emake || die
}