summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mozilla-thunderbird/mozilla-thunderbird-0.2.ebuild')
-rw-r--r--net-mail/mozilla-thunderbird/mozilla-thunderbird-0.2.ebuild177
1 files changed, 86 insertions, 91 deletions
diff --git a/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.2.ebuild b/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.2.ebuild
index 57ed12619cae..3211a99f6aea 100644
--- a/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.2.ebuild
+++ b/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.2.ebuild,v 1.1 2003/09/04 19:29:29 brad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.2.ebuild,v 1.2 2003/09/05 02:20:58 msterret Exp $
inherit makeedit flag-o-matic gcc nsplugins
@@ -36,13 +36,13 @@ RDEPEND="virtual/x11
app-arch/zip
app-arch/unzip
( gtk2? >=x11-libs/gtk+-2.1.1 :
- =x11-libs/gtk+-1.2* )
- crypt? ( >=app-crypt/gnupg-1.2.1 )"
+ =x11-libs/gtk+-1.2* )
+ crypt? ( >=app-crypt/gnupg-1.2.1 )"
DEPEND="${RDEPEND}
virtual/glibc
dev-lang/perl"
-
+
# needed by src_compile() and src_install()
export MOZ_THUNDERBIRD=1
export MOZ_ENABLE_XFT=1
@@ -75,80 +75,80 @@ src_unpack() {
}
src_compile() {
- local myconf="--with-x \
- --with-system-jpeg \
- --with-system-zlib \
- --with-system-png \
- --with-system-mng \
- --disable-calendar \
- --enable-xft \
- --disable-pedantic \
- --disable-svg \
- --enable-mathml \
- --without-system-nspr \
- --enable-nspr-autoconf \
- --enable-xsl \
- --enable-crypto \
- --enable-xinerama=no \
- --with-pthreads \
- --with-default-mozilla-five-home=/usr/lib/MozillaThunderbird \
- --with-user-appdir=.thunderbird \
- --disable-jsd \
- --disable-accessibility \
- --disable-profilesharing \
- --disable-necko-disk-cache \
- --disable-activex-scripting \
- --disable-installer \
- --disable-activex \
- --disable-tests \
- --disable-debug \
- --disable-dtd-debug \
- --disable-logging \
- --enable-reorder \
- --enable-optimize="-O2" \
- --enable-strip \
- --enable-strip-libs \
- --enable-cpp-rtti \
- --enable-xterm-updates \
- --disable-toolkit-qt \
- --disable-toolkit-xlib \
- --enable-extensions=wallet \
- --enable-necko-protocols=http,file,jar,viewsource,res,data \
- --enable-image-decoders=png,gif,jpeg"
-
- if [ -n "`use gtk2`" ] ; then
- myconf="${myconf} --enable-toolkit-gtk2 \
- --enable-default-toolkit=gtk2 \
- --disable-toolkit-gtk"
- else
- myconf="${myconf} --enable-toolkit-gtk \
- --enable-default-toolkit=gtk \
- --disable-toolkit-gtk2"
- fi
-
- if [ -n "`use ipv6`" ] ; then
- myconf="${myconf} --enable-ipv6"
- fi
-
- # Crashes on start when compiled with -fomit-frame-pointer
- filter-flags -fomit-frame-pointer
- filter-flags -ffast-math
- append-flags -s -fforce-addr
-
- if [ "$(gcc-major-version)" -eq "3" ]; then
- # Currently gcc-3.2 or older do not work well if we specify "-march"
- # and other optimizations for pentium4.
- if [ "$(gcc-minor-version)" -lt "3" ]; then
- replace-flags -march=pentium4 -march=pentium3
- filter-flags -msse2
- fi
-
- fi
-
- econf ${myconf} || die
-
- edit_makefiles
- emake MOZ_THUNDERBIRD=1 || die
+ local myconf="--with-x \
+ --with-system-jpeg \
+ --with-system-zlib \
+ --with-system-png \
+ --with-system-mng \
+ --disable-calendar \
+ --enable-xft \
+ --disable-pedantic \
+ --disable-svg \
+ --enable-mathml \
+ --without-system-nspr \
+ --enable-nspr-autoconf \
+ --enable-xsl \
+ --enable-crypto \
+ --enable-xinerama=no \
+ --with-pthreads \
+ --with-default-mozilla-five-home=/usr/lib/MozillaThunderbird \
+ --with-user-appdir=.thunderbird \
+ --disable-jsd \
+ --disable-accessibility \
+ --disable-profilesharing \
+ --disable-necko-disk-cache \
+ --disable-activex-scripting \
+ --disable-installer \
+ --disable-activex \
+ --disable-tests \
+ --disable-debug \
+ --disable-dtd-debug \
+ --disable-logging \
+ --enable-reorder \
+ --enable-optimize="-O2" \
+ --enable-strip \
+ --enable-strip-libs \
+ --enable-cpp-rtti \
+ --enable-xterm-updates \
+ --disable-toolkit-qt \
+ --disable-toolkit-xlib \
+ --enable-extensions=wallet \
+ --enable-necko-protocols=http,file,jar,viewsource,res,data \
+ --enable-image-decoders=png,gif,jpeg"
+
+ if [ -n "`use gtk2`" ] ; then
+ myconf="${myconf} --enable-toolkit-gtk2 \
+ --enable-default-toolkit=gtk2 \
+ --disable-toolkit-gtk"
+ else
+ myconf="${myconf} --enable-toolkit-gtk \
+ --enable-default-toolkit=gtk \
+ --disable-toolkit-gtk2"
+ fi
+
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ # Crashes on start when compiled with -fomit-frame-pointer
+ filter-flags -fomit-frame-pointer
+ filter-flags -ffast-math
+ append-flags -s -fforce-addr
+
+ if [ "$(gcc-major-version)" -eq "3" ]; then
+ # Currently gcc-3.2 or older do not work well if we specify "-march"
+ # and other optimizations for pentium4.
+ if [ "$(gcc-minor-version)" -lt "3" ]; then
+ replace-flags -march=pentium4 -march=pentium3
+ filter-flags -msse2
+ fi
+
+ fi
+
+ econf ${myconf} || die
+
+ edit_makefiles
+ emake MOZ_THUNDERBIRD=1 || die
# Build the enigmail plugin
if use crypt
@@ -156,23 +156,21 @@ src_compile() {
einfo "Building Enigmail plugin..."
cd ${S}/extensions/ipc
make || die
-
+
cd ${S}/extensions/enigmail
make || die
fi
-
}
src_install() {
+ dodir /usr/lib
+ dodir /usr/lib/MozillaThunderbird
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaThunderbird
- dodir /usr/lib
- dodir /usr/lib/MozillaThunderbird
- cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaThunderbird
+ #fix permissions
+ chown -R root.root ${D}/usr/lib/MozillaThunderbird
- #fix permissions
- chown -R root.root ${D}/usr/lib/MozillaThunderbird
-
- dobin ${FILESDIR}/MozillaThunderbird
+ dobin ${FILESDIR}/MozillaThunderbird
# Install icon and .desktop for menu entry
if [ "`use gnome`" ]
@@ -190,14 +188,12 @@ src_install() {
insinto /usr/share/gnome/apps/Internet
doins ${S}/build/package/rpm/SOURCES/mozillathunderbird.desktop
fi
-
}
pkg_postinst() {
-
export MOZILLA_FIVE_HOME="${ROOT}/usr/lib/MozillaThunderbird"
- # Needed to update the run time bindings for REGXPCOM
+ # Needed to update the run time bindings for REGXPCOM
# (do not remove next line!)
env-update
# Register Components and Chrome
@@ -210,5 +206,4 @@ pkg_postinst() {
find ${MOZILLA_FIVE_HOME}/ -type d -perm 0700 -exec chmod 0755 {} \; || :
# Fix permissions on chrome files
find ${MOZILLA_FIVE_HOME}/chrome/ -name '*.rdf' -exec chmod 0644 {} \; || :
-
}