summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/gyach/gyach-0.9.1-r1.ebuild')
-rw-r--r--net-misc/gyach/gyach-0.9.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/gyach/gyach-0.9.1-r1.ebuild b/net-misc/gyach/gyach-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..7d0805fdccc5
--- /dev/null
+++ b/net-misc/gyach/gyach-0.9.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gyach/gyach-0.9.1-r1.ebuild,v 1.1 2003/01/16 07:08:55 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+-based Yahoo! chat client"
+SRC_URI="http://www4.infi.net/~cpinkham/gyach/code/${P}.tar.gz"
+HOMEPAGE="http://www4.infi.net/~cpinkham/gyach/"
+KEYWORDS="x86 sparc "
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/glibc
+ =x11-libs/gtk+-2*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && patch -p1 <${FILESDIR}/gyach-0.9.1-gtk2.2-gentoo.patch || die
+}
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README* TODO
+ dodoc sample.*
+
+ # install icon and desktop entry for gnome
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/pixmaps
+ doins ${D}/usr/share/gyach/pixmaps/gyach-icon.xpm
+ insinto /usr/share/gnome/apps/Internet
+ doins ${FILESDIR}/gyach.desktop
+ fi
+
+}