summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/hylafax/hylafax-4.1.8-r1.ebuild')
-rw-r--r--net-misc/hylafax/hylafax-4.1.8-r1.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/net-misc/hylafax/hylafax-4.1.8-r1.ebuild b/net-misc/hylafax/hylafax-4.1.8-r1.ebuild
index 22747cac760e..a1984555477a 100644
--- a/net-misc/hylafax/hylafax-4.1.8-r1.ebuild
+++ b/net-misc/hylafax/hylafax-4.1.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.1.8-r1.ebuild,v 1.5 2004/04/19 22:12:34 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.1.8-r1.ebuild,v 1.6 2004/04/26 01:44:35 nerdboy Exp $
# This is basically unchanged from the one supplied by Stephane Loeuillet
# to Gentoo bug: http://bugs.gentoo.org/show_bug.cgi?id=28574
@@ -9,7 +9,6 @@
IUSE="jpeg"
-S=${WORKDIR}/${P}
DESCRIPTION="Client-server fax package for class 1 and 2 fax modems."
HOMEPAGE="http://www.hylafax.org"
SRC_URI="ftp://ftp.hylafax.org/source/${P}.tar.gz"
@@ -44,10 +43,13 @@ src_compile() {
--with-PATH_VGETTY=/sbin/vgetty \
--with-PATH_GETTY=/sbin/agetty \
--with-HTML=no \
+ --with-PS=auto \
+ --with-PATH_GSRIP=/usr/bin/gs \
--with-PATH_DPSRIP=/var/spool/fax/bin/ps2fax \
--with-PATH_IMPRIP=/usr/share/fax/psrip \
--with-SYSVINIT=/etc/init.d \
--with-INTERACTIVE=no \
+ --with-LIBTIFF="-ltiff -ljpeg -lz" \
--with-OPTIMIZER="${CFLAGS}" || die
# no 'emake' for the same reason (might use an old automake version)
make || die
@@ -82,3 +84,12 @@ src_install() {
dohtml -r html/
keepdir /usr/share/doc/${P}
}
+
+pkg_postinst() {
+ ewarn "Proper fax2tiff support now requires libtiff 3.5.5 until there"
+ ewarn "is an upstream fix for bug #48077. You must use this version"
+ ewarn "of fax2tiff if you need conversion of G3 files, however, you"
+ ewarn "you must still build hylafax against tiff-3.5.7-r1 or better."
+ ewarn "I repeat: do not try to build hylafax or anything else against"
+ ewarn "tiff-3.5.5 because it won't work. You've been warned."
+}