summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/nemesis/nemesis-1.32.ebuild')
-rw-r--r--net-misc/nemesis/nemesis-1.32.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/nemesis/nemesis-1.32.ebuild b/net-misc/nemesis/nemesis-1.32.ebuild
new file mode 100644
index 000000000000..bc9604d81103
--- /dev/null
+++ b/net-misc/nemesis/nemesis-1.32.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Alexander Gretencord <arutha@gmx.de>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nemesis/nemesis-1.32.ebuild,v 1.1 2002/04/23 19:43:58 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A commandline-based, portable human IP stack for UNIX/Linux"
+SRC_URI="http://jeff.wwti.com/nemesis/${P}.tar.gz"
+HOMEPAGE="http://jeff.wwti.com/nemesis/"
+
+RDEPEND="virtual/glibc >=net-libs/libpcap-0.6.2-r1"
+DEPEND="${RDEPEND} >=net-libs/libnet-1.0.2a"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+ dodir /usr/sbin /usr/share/man/man1
+ make DESTDIR=${D} install || die
+}