summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/hylafax/ChangeLog9
-rw-r--r--net-misc/hylafax/Manifest4
-rw-r--r--net-misc/hylafax/files/digest-hylafax-4.1.7-r11
-rw-r--r--net-misc/hylafax/hylafax-4.1.7-r1.ebuild80
4 files changed, 90 insertions, 4 deletions
diff --git a/net-misc/hylafax/ChangeLog b/net-misc/hylafax/ChangeLog
index 5f174791c751..f9176425adb0 100644
--- a/net-misc/hylafax/ChangeLog
+++ b/net-misc/hylafax/ChangeLog
@@ -1,8 +1,13 @@
# ChangeLog for net-misc/hylafax
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.17 2003/09/24 06:28:47 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.18 2003/10/04 03:19:56 nerdboy Exp $
- 23 Sep 2003; <sarnold@gentoo.org> hylafax-4.1.7.ebuild:
+*hylafax-4.1.7-r1 (03 Oct 2003)
+
+ 03 Oct 2003; <nerdboy@gentoo.org> hylafax-4.1.7-r1.ebuild:
+ added autoreconf for new gcc 3.3.1 version output
+
+ 23 Sep 2003; <nerdboy@gentoo.org> hylafax-4.1.7.ebuild:
changed keywords to x86
22 Sep 2003; <paul@gentoo.org> metadata.xml:
diff --git a/net-misc/hylafax/Manifest b/net-misc/hylafax/Manifest
index e7368bc1d208..7c76f56ca222 100644
--- a/net-misc/hylafax/Manifest
+++ b/net-misc/hylafax/Manifest
@@ -1,8 +1,8 @@
-MD5 7240227a2f38574d21c567c792d92023 ChangeLog 4272
+MD5 57ee55c209de3fae49efb123701e73cd ChangeLog 4272
MD5 6057f28d0a94aa5ef3a23980ff473676 hylafax-4.1.5.ebuild 1714
MD5 0035400761422f75b958a55adf5773b2 hylafax-4.1.7.ebuild 2133
MD5 d82acf1bcf0f7f9e181d6a2821292f2e metadata.xml 435
-MD5 5a1b44d19fcbdcb027b2ecc327931cca hylafax-4.1.7-r1.ebuild 2083
+MD5 11e339da42f99c9b62149abfc16a5e03 hylafax-4.1.7-r1.ebuild 2187
MD5 2ebb269cf0ba67d69d582a3f139c11e5 files/digest-hylafax-4.1.5 66
MD5 620e9bbfd90a0fad3a5324cac04ffc81 files/hylafax-4.1.2-gentoo-diffs.tar.bz2 3993
MD5 2db231b7619b5613bc06da8711626b05 files/digest-hylafax-4.1.7 66
diff --git a/net-misc/hylafax/files/digest-hylafax-4.1.7-r1 b/net-misc/hylafax/files/digest-hylafax-4.1.7-r1
new file mode 100644
index 000000000000..cff01ad567c0
--- /dev/null
+++ b/net-misc/hylafax/files/digest-hylafax-4.1.7-r1
@@ -0,0 +1 @@
+MD5 1302066b0055a060e525026919d98ff7 hylafax-4.1.7.tar.gz 1285766
diff --git a/net-misc/hylafax/hylafax-4.1.7-r1.ebuild b/net-misc/hylafax/hylafax-4.1.7-r1.ebuild
new file mode 100644
index 000000000000..a3a305cd4fa8
--- /dev/null
+++ b/net-misc/hylafax/hylafax-4.1.7-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.1.7-r1.ebuild,v 1.1 2003/10/04 03:19:56 nerdboy Exp $
+
+# This is basically unchanged from the one supplied by Stephane Loeuillet
+# to Gentoo bug: http://bugs.gentoo.org/show_bug.cgi?id=28574
+# Nice job, and thanks :)
+# Now with autoreconf for new gcc.
+
+IUSE="jpeg"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Client-server fax package for class 1 and 2 fax modems."
+HOMEPAGE="http://www.hylafax.org"
+SRC_URI="ftp://ftp.hylafax.org/source/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="hylafax"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="net-dialup/mgetty
+ >=sys-libs/zlib-1.1.4
+ >=app-text/ghostscript-5.50
+ >=media-libs/tiff-3.5.5
+ jpeg? ( media-libs/jpeg )
+ sys-apps/gawk"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # no 'econf' here because does not support standard --prefix option (prehistoric autoconf v1.92 used !!!)
+ autoreconf -f
+ ./configure \
+ --with-DIR_BIN=/usr/bin \
+ --with-DIR_SBIN=/usr/sbin \
+ --with-DIR_LIB=/usr/lib \
+ --with-DIR_LIBEXEC=/usr/sbin \
+ --with-DIR_LIBDATA=/usr/lib/fax \
+ --with-DIR_LOCKS=/var/lock \
+ --with-DIR_MAN=/usr/share/man \
+ --with-DIR_SPOOL=/var/spool/fax \
+ --with-AFM=no \
+ --with-AWK=/usr/bin/gawk \
+ --with-PATH_VGETTY=/sbin/vgetty \
+ --with-PATH_GETTY=/sbin/agetty \
+ --with-HTML=no \
+ --with-PATH_DPSRIP=/var/spool/fax/bin/ps2fax \
+ --with-PATH_IMPRIP=/usr/share/fax/psrip \
+ --with-SYSVINIT=/etc/init.d \
+ --with-INTERACTIVE=no \
+ --with-OPTIMIZER="${CFLAGS}" || die
+ # no 'emake' for the same reason (might use an old automake version)
+ make || die
+}
+
+src_install() {
+
+ dodir /usr/{bin,sbin} /usr/lib/fax /usr/share/man \
+ /var/spool/fax/{archive,client,pollq,recvq,tmp}
+ chown -R uucp:uucp ${D}/var/spool/fax
+
+ make \
+ BIN=${D}/usr/bin \
+ SBIN=${D}/usr/sbin \
+ LIBDIR=${D}/usr/lib \
+ LIB=${D}/usr/lib \
+ LIBEXEC=${D}/usr/sbin \
+ LIBDATA=${D}/usr/lib/fax \
+ MAN=${D}/usr/share/man \
+ SPOOL=${D}/var/spool/fax \
+ install || die
+
+ insinto /etc/init.d
+ insopts -m 755
+ doins etc/hylafax
+
+ dodoc COPYRIGHT README TODO VERSION
+
+ dohtml -r html/
+}