summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openvpn/ChangeLog9
-rw-r--r--net-misc/openvpn/files/openvpn-2.1_rc7-tap.patch57
-rw-r--r--net-misc/openvpn/openvpn-2.1_rc9.ebuild (renamed from net-misc/openvpn/openvpn-2.1_rc7-r2.ebuild)10
3 files changed, 10 insertions, 66 deletions
diff --git a/net-misc/openvpn/ChangeLog b/net-misc/openvpn/ChangeLog
index d33c708c3c99..3eb2daed0d54 100644
--- a/net-misc/openvpn/ChangeLog
+++ b/net-misc/openvpn/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/openvpn
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.135 2008/05/14 17:02:24 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.136 2008/08/01 09:03:43 cedk Exp $
+
+*openvpn-2.1_rc9 (01 Aug 2008)
+
+ 01 Aug 2008; Cédric Krier <cedk@gentoo.org>
+ -files/openvpn-2.1_rc7-tap.patch, -openvpn-2.1_rc7-r2.ebuild,
+ +openvpn-2.1_rc9.ebuild:
+ Version bump
*openvpn-2.0.9 (14 May 2008)
diff --git a/net-misc/openvpn/files/openvpn-2.1_rc7-tap.patch b/net-misc/openvpn/files/openvpn-2.1_rc7-tap.patch
deleted file mode 100644
index 5bd11ad103b2..000000000000
--- a/net-misc/openvpn/files/openvpn-2.1_rc7-tap.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-Index: tun.c
-===================================================================
---- tun.c (revision 2713)
-+++ tun.c (revision 2715)
-@@ -1220,26 +1220,44 @@
- {
- if (tt)
- {
--#ifdef CONFIG_FEATURE_IPROUTE
- if (tt->type != DEV_TYPE_NULL && tt->did_ifconfig)
- {
- char command_line[256];
- struct gc_arena gc = gc_new ();
-
-+#ifdef CONFIG_FEATURE_IPROUTE
-+ if (is_tun_p2p (tt))
-+ {
-+ openvpn_snprintf (command_line, sizeof (command_line),
-+ "%s addr del dev %s local %s peer %s",
-+ iproute_path,
-+ tt->actual_name,
-+ print_in_addr_t (tt->local, 0, &gc),
-+ print_in_addr_t (tt->remote_netmask, 0, &gc)
-+ );
-+ }
-+ else
-+ {
-+ openvpn_snprintf (command_line, sizeof (command_line),
-+ "%s addr del dev %s %s/%d",
-+ iproute_path,
-+ tt->actual_name,
-+ print_in_addr_t (tt->local, 0, &gc),
-+ count_netmask_bits(print_in_addr_t (tt->remote_netmask, 0, &gc))
-+ );
-+ }
-+#else
- openvpn_snprintf (command_line, sizeof (command_line),
-- "%s addr del dev %s local %s peer %s",
-- iproute_path,
-- tt->actual_name,
-- print_in_addr_t (tt->local, 0, &gc),
-- print_in_addr_t (tt->remote_netmask, 0, &gc)
-- );
-+ IFCONFIG_PATH " %s 0.0.0.0",
-+ tt->actual_name
-+ );
-+#endif
-
- msg (M_INFO, "%s", command_line);
- system_check (command_line, NULL, S_FATAL, "Linux ip addr del failed");
-
- gc_free (&gc);
- }
--#endif
- close_tun_generic (tt);
- free (tt);
- }
diff --git a/net-misc/openvpn/openvpn-2.1_rc7-r2.ebuild b/net-misc/openvpn/openvpn-2.1_rc9.ebuild
index 291e73e8004a..06692ed8277a 100644
--- a/net-misc/openvpn/openvpn-2.1_rc7-r2.ebuild
+++ b/net-misc/openvpn/openvpn-2.1_rc9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.1_rc7-r2.ebuild,v 1.1 2008/04/18 06:22:44 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.1_rc9.ebuild,v 1.1 2008/08/01 09:03:43 cedk Exp $
inherit eutils multilib
@@ -32,12 +32,6 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-tap.patch"
-}
-
src_compile() {
local myconf=""
@@ -63,7 +57,7 @@ src_compile() {
if ! use minimal ; then
cd plugin
for i in $( ls 2>/dev/null ); do
- [[ ${i} == "README" || ${i} == "examples" ]] && continue
+ [[ ${i} == "README" || ${i} == "examples" || ${i} == "defer" ]] && continue
[[ ${i} == "auth-pam" ]] && ! use pam && continue
einfo "Building ${i} plugin"
cd "${i}"