summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ifenslave/ChangeLog9
-rw-r--r--net-misc/ifenslave/ifenslave-1.1.0-r5.ebuild61
2 files changed, 69 insertions, 1 deletions
diff --git a/net-misc/ifenslave/ChangeLog b/net-misc/ifenslave/ChangeLog
index 4df1c1c00fda..72a9cb254a69 100644
--- a/net-misc/ifenslave/ChangeLog
+++ b/net-misc/ifenslave/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/ifenslave
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ifenslave/ChangeLog,v 1.19 2009/04/12 20:49:06 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ifenslave/ChangeLog,v 1.20 2009/07/05 20:05:42 robbat2 Exp $
+
+*ifenslave-1.1.0-r5 (05 Jul 2009)
+
+ 05 Jul 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +ifenslave-1.1.0-r5.ebuild:
+ Version bump to latest debian patchset, also update modprobe.d file to
+ have .conf suffix for new modprobe.
12 Apr 2009; Robin H. Johnson <robbat2@gentoo.org>
-ifenslave-1.1.0.ebuild, -ifenslave-1.1.0-r1.ebuild,
diff --git a/net-misc/ifenslave/ifenslave-1.1.0-r5.ebuild b/net-misc/ifenslave/ifenslave-1.1.0-r5.ebuild
new file mode 100644
index 000000000000..ced93f780132
--- /dev/null
+++ b/net-misc/ifenslave/ifenslave-1.1.0-r5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ifenslave/ifenslave-1.1.0-r5.ebuild,v 1.1 2009/07/05 20:05:42 robbat2 Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Attach and detach slave interfaces to a bonding device"
+HOMEPAGE="http://sf.net/projects/bonding/"
+MY_PN="ifenslave-2.6" # this is NOT an error
+DEBIAN_PV="13"
+DEBIANPKG_TARBALL="${MY_PN}_${PV}.orig.tar.gz"
+DEBIANPKG_PATCH="${MY_PN}_${PV}-${DEBIAN_PV}.diff.gz"
+DEBIANPKG_BASE="mirror://debian/pool/main/${MY_PN:0:1}/${MY_PN}"
+SRC_URI="${DEBIANPKG_BASE}/${DEBIANPKG_TARBALL}
+ ${DEBIANPKG_BASE}/${DEBIANPKG_PATCH}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+RDEPEND="virtual/libc"
+DEPEND="sys-devel/gcc
+ >=sys-kernel/linux-headers-2.4.22
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${DEBIANPKG_TARBALL}
+ EPATCH_OPTS="-d ${S} -p1" epatch "${DISTDIR}"/${DEBIANPKG_PATCH}
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} ${PN}.c -o ${PN} || die "Failed to compile!"
+}
+
+src_install() {
+ doman ${PN}.8
+ into /
+ dosbin ${PN}
+ # there really is no better documentation than the sourcecode :-)
+ dodoc ${PN}.c
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/modules.d-bond-1.1.0-r3 bond.conf
+}
+
+pkg_preinst() {
+ if [[ -a /etc/modules.d/bond ]] && [[ ! -a /etc/modprobe.d/bond ]]; then
+ elog "Moving old bond configuration in modules.d to new"
+ elog "location in modprobe.d in /etc/"
+ mv "${ROOT}"/etc/{modules,modprobe}.d/bond
+ fi
+ if [[ -a /etc/modprobe.d/bond ]] && [[ ! -a /etc/modprobe.d/bond.conf ]]; then
+ elog "Moving old bond configuration in modprobe.d to"
+ elog "new naming scheme with trailing .conf"
+ mv "${ROOT}"/etc/modprobe.d/bond{,.conf}
+ fi
+}
+
+pkg_postinst() {
+ einfo "If you want to use bonding on your system, be sure to use"
+ einfo ">=baselayout-1.10, where support is now integrated!"
+ einfo "Using >=baselayout-1.11.6 strongly recommended."
+}