summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/openldap/openldap-2.4.21.ebuild')
-rw-r--r--net-nds/openldap/openldap-2.4.21.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-nds/openldap/openldap-2.4.21.ebuild b/net-nds/openldap/openldap-2.4.21.ebuild
index 3d968581601e..a2e45619fd82 100644
--- a/net-nds/openldap/openldap-2.4.21.ebuild
+++ b/net-nds/openldap/openldap-2.4.21.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.4.21.ebuild,v 1.3 2012/02/10 18:10:03 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.4.21.ebuild,v 1.4 2012/02/12 00:54:14 robbat2 Exp $
EAPI="2"
-inherit db-use eutils flag-o-matic multilib ssl-cert versionator toolchain-funcs
+WANT_AUTOMAKE=none
+inherit db-use eutils flag-o-matic multilib ssl-cert versionator toolchain-funcs autotools
DESCRIPTION="LDAP suite of application and development tools"
HOMEPAGE="http://www.OpenLDAP.org/"
@@ -237,6 +238,9 @@ src_prepare() {
# bug #233633
epatch "${FILESDIR}"/${PN}-2.4.17-fix-lmpasswd-gnutls-symbols.patch
+ # bug #281495
+ epatch "${FILESDIR}"/${PN}-2.4.28-gnutls-gcrypt.patch
+
cd "${S}"/build
einfo "Making sure upstream build strip does not do stripping too early"
sed -i.orig \
@@ -247,6 +251,11 @@ src_prepare() {
sed -i \
-e 's|/bin/sh|/bin/bash|g' \
"${S}"/tests/scripts/* || die "sed failed"
+
+ cd "${S}"
+ #sed '/AM_INIT_AUTOMAKE/s,^,#,g' -i configure.in || die "sed failed"
+ eautoreconf
+ #sed '/AM_INIT_AUTOMAKE/s,^#,,g' -i configure.in || die "sed failed"
}
build_contrib_module() {