summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/bittorrent/bittorrent-5.0.5.ebuild')
-rw-r--r--net-p2p/bittorrent/bittorrent-5.0.5.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/net-p2p/bittorrent/bittorrent-5.0.5.ebuild b/net-p2p/bittorrent/bittorrent-5.0.5.ebuild
new file mode 100644
index 000000000000..6e0da2bbbd80
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-5.0.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-5.0.5.ebuild,v 1.1 2007/01/19 18:49:31 armin76 Exp $
+
+inherit distutils fdo-mime eutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://download.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="gtk"
+
+RDEPEND=">=dev-lang/python-2.3
+ gtk? (
+ >=x11-libs/wxGTK-2.6
+ >=dev-python/wxpython-2.6
+ )
+ >=dev-python/pycrypto-2.0
+ >=dev-python/twisted-2
+ dev-python/twisted-web
+ net-zope/zopeinterface
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+PROVIDE="virtual/bittorrent"
+
+DOCS="README.txt TRACKERLESS.txt public.key credits.txt"
+PYTHON_MODNAME="BitTorrent"
+
+pkg_setup() {
+ if use gtk ; then
+ if ! built_with_use x11-libs/wxGTK unicode ; then
+ die "You must build wxGTK and wxpython with unicode support"
+ fi
+ if ! built_with_use dev-python/wxpython unicode ; then
+ die "You must build wxGTK and wxpython with unicode support"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # path for documentation is in lowercase #109743
+ sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
+}
+
+src_install() {
+ distutils_src_install
+ use gtk || rm -f "${D}"/usr/bin/bittorrent
+ dohtml redirdonate.html
+
+ if use gtk ; then
+ doicon images/logo/bittorrent.ico
+ newicon images/logo/bittorrent_icon_32.png bittorrent.png
+ make_desktop_entry "bittorrent" "BitTorrent" bittorrent.png "Network"
+ echo "MimeType=application/x-bittorrent" \
+ >> "${D}"/usr/share/applications/bittorrent-${PN}.desktop
+ fi
+
+ newinitd "${FILESDIR}"/bittorrent-tracker.initd bittorrent-tracker
+ newconfd "${FILESDIR}"/bittorrent-tracker.confd bittorrent-tracker
+}
+
+pkg_postinst() {
+ einfo "Remember that BitTorrent has changed file naming scheme"
+ einfo "To run BitTorrent just execute /usr/bin/bittorrent"
+ einfo "To run the init.d, please use /etc/init.d/bittorrent-tracker"
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}