summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/lince/lince-0.99.ebuild')
-rw-r--r--net-p2p/lince/lince-0.99.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-p2p/lince/lince-0.99.ebuild b/net-p2p/lince/lince-0.99.ebuild
new file mode 100644
index 000000000000..3a2ec1566701
--- /dev/null
+++ b/net-p2p/lince/lince-0.99.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/lince-0.99.ebuild,v 1.1 2008/03/01 16:15:10 coldwind Exp $
+
+DESCRIPTION="a light, powerfull and full feature gtkmm bittorrent client"
+SRC_URI="mirror://sourceforge/lincetorrent/${P}.tar.gz"
+HOMEPAGE="http://lincetorrent.sourceforge.net"
+
+DEPEND="dev-cpp/gtkmm
+ x11-libs/cairo
+ >=net-libs/rb_libtorrent-0.13_pre1912
+ dev-libs/libxml2"
+
+RDEPEND="${DEPEND}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="nls"
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+}