summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/hrktorrent/ChangeLog7
-rw-r--r--net-p2p/hrktorrent/hrktorrent-0.3.2.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/net-p2p/hrktorrent/ChangeLog b/net-p2p/hrktorrent/ChangeLog
index f4cd68c9118a..d9c577c9b334 100644
--- a/net-p2p/hrktorrent/ChangeLog
+++ b/net-p2p/hrktorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/hrktorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/ChangeLog,v 1.10 2008/06/05 18:13:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/ChangeLog,v 1.11 2008/06/30 16:19:39 drac Exp $
+
+*hrktorrent-0.3.2 (30 Jun 2008)
+
+ 30 Jun 2008; Samuli Suominen <drac@gentoo.org> +hrktorrent-0.3.2.ebuild:
+ Version bump wrt #230215, tanks to Sebastian Mair for reporting.
05 Jun 2008; Raúl Porcel <armin76@gentoo.org> -hrktorrent-0.3.0.ebuild,
hrktorrent-0.3.1.ebuild:
diff --git a/net-p2p/hrktorrent/hrktorrent-0.3.2.ebuild b/net-p2p/hrktorrent/hrktorrent-0.3.2.ebuild
new file mode 100644
index 000000000000..dc49a1faf962
--- /dev/null
+++ b/net-p2p/hrktorrent/hrktorrent-0.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/hrktorrent-0.3.2.ebuild,v 1.1 2008/06/30 16:19:39 drac Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A slim rb_libtorrent based console torrent application supporting DHT"
+HOMEPAGE="http://henrik.unit5.ca/hrktorrent"
+SRC_URI="http://henrik.unit5.ca/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/rb_libtorrent-0.12"
+DEPEND="${RDEPEND}
+ dev-cpp/asio
+ dev-util/pkgconfig"
+
+src_compile() {
+ tc-export CXX
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed."
+ doman ${PN}.1
+ dodoc CHANGELOG README ${PN}.rc.example
+}
+
+pkg_postinst() {
+ elog "Extract ${PN}.rc.example from /usr/share/doc/${PF} to"
+ elog "home ~/.${PN}/${PN}.rc for example config."
+}