summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/swish-e/swish-e-2.2.2-r1.ebuild')
-rw-r--r--net-www/swish-e/swish-e-2.2.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-www/swish-e/swish-e-2.2.2-r1.ebuild b/net-www/swish-e/swish-e-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..5817d9ac07f1
--- /dev/null
+++ b/net-www/swish-e/swish-e-2.2.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/swish-e/swish-e-2.2.2-r1.ebuild,v 1.1 2003/07/20 14:13:48 mcummings Exp $
+
+use perl && inherit perl-module
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Simple Web Indexing System for Humans - Enhanced"
+SRC_URI="http://www.swish-e.org/Download/${P}.tar.gz"
+HOMEPAGE="http://www.swish-e.org"
+IUSE="perl"
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ dev-libs/libxml2
+ dev-perl/libwww-perl"
+
+src_compile() {
+
+ econf || die "configuration failed"
+
+ emake || die "emake failed"
+ # closing stdin causes e-swish build system use a
+ # non-interactive mode <mkennedy@gentoo.org>
+ use perl && cd perl \
+ && exec <&- \
+ && perl-module_src_compile
+
+}
+
+src_install () {
+
+ dobin src/swish-e
+ dodoc INSTALL README
+ use perl && cd perl \
+ && perl-module_src_install
+}