summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/staden/staden-1.5.3.ebuild')
-rw-r--r--sci-biology/staden/staden-1.5.3.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/sci-biology/staden/staden-1.5.3.ebuild b/sci-biology/staden/staden-1.5.3.ebuild
index 0d0a5891b7fc..7f14ec42e436 100644
--- a/sci-biology/staden/staden-1.5.3.ebuild
+++ b/sci-biology/staden/staden-1.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/staden/staden-1.5.3.ebuild,v 1.3 2005/01/25 04:19:24 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/staden/staden-1.5.3.ebuild,v 1.4 2005/01/30 18:21:09 ribosome Exp $
inherit eutils toolchain-funcs
@@ -76,7 +76,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}-mutlib-gcc-3.4.patch
cd ${S}/src/mk
# Remove the "-fpic" flag. This will be replaced by "-fPIC".
- sed -i -e 's/SHLIB_CFLAGS = -fpic/SHLIB_CFLAGS = /' linux.mk
+ sed -i -e 's/SHLIB_CFLAGS = -fpic/SHLIB_CFLAGS = /' linux.mk || die
cd ${S}
# "getopt" is incorrectly included as an extern (for Win32 compatibility).
@@ -99,15 +99,15 @@ src_unpack() {
# Documentation build process cannot find "update-nodes.el".
cd ${S}/doc/manual/tools
- sed -i -e 's%emacs -batch $1 -l ${DOCDIR:-.}/tools/update-nodes.el%emacs -batch $1 -l ${DOCDIR:-..}/manual/tools/update-nodes.el%' update-nodes
+ sed -i -e 's%emacs -batch $1 -l ${DOCDIR:-.}/tools/update-nodes.el%emacs -batch $1 -l ${DOCDIR:-..}/manual/tools/update-nodes.el%' update-nodes || die
# Perl scripts search for "pearl" in "/usr/local".
for SCRIPT in *.pl texi2html; do
- sed -i -e 's%/usr/local/bin/perl%/usr/bin/perl%' ${SCRIPT}
+ sed -i -e 's%/usr/local/bin/perl%/usr/bin/perl%' ${SCRIPT} || die
done
# The "convert" tool from Imagemagick is searched for in "/usr/X11R6".
- sed -i -e 's%/usr/X11R6/bin/convert%/usr/bin/convert%' make_ps
+ sed -i -e 's%/usr/X11R6/bin/convert%/usr/bin/convert%' make_ps | die
# Solves issues with images in the exercise* texi files.
cd ${S}/course/texi
@@ -120,8 +120,9 @@ src_unpack() {
# system global Makefile. We also want only "-fPIC" shared libraries.
einfo "Applying user-defined compilation/linking flags:"
cd ${S}/src/mk
- sed -i -e "s/COPT = -O2 -g3 -DNDEBUG/COPT = ${CFLAGS:-"-O2 -g3 -DNDEBUG"} -fPIC/" global.mk
- sed -i -e "s/FOPT = -O2 -g3 -DNDEBUG/FOPT = ${FFLAGS:-"-O2 -g3 -DNDEBUG"} -fPIC/" global.mk
+ sed -e "s/COPT = -O2 -g3 -DNDEBUG/COPT = ${CFLAGS:-"-O2 -g3 -DNDEBUG"} -fPIC/" \
+ -e "s/FOPT = -O2 -g3 -DNDEBUG/FOPT = ${FFLAGS:-"-O2 -g3 -DNDEBUG"} -fPIC/" \
+ -i global.mk || die
}
src_compile() {