summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/calcoo')
-rw-r--r--sci-calculators/calcoo/ChangeLog8
-rw-r--r--sci-calculators/calcoo/calcoo-1.3.18.ebuild23
-rw-r--r--sci-calculators/calcoo/files/calcoo-1.3.18-gold.patch16
-rw-r--r--sci-calculators/calcoo/metadata.xml2
4 files changed, 36 insertions, 13 deletions
diff --git a/sci-calculators/calcoo/ChangeLog b/sci-calculators/calcoo/ChangeLog
index d2c607738f24..2c85a1420208 100644
--- a/sci-calculators/calcoo/ChangeLog
+++ b/sci-calculators/calcoo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-calculators/calcoo
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/calcoo/ChangeLog,v 1.17 2011/03/02 13:26:37 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/calcoo/ChangeLog,v 1.18 2012/04/26 16:06:34 jlec Exp $
+
+ 26 Apr 2012; Justin Lecher <jlec@gentoo.org> calcoo-1.3.18.ebuild,
+ +files/calcoo-1.3.18-gold.patch, metadata.xml:
+ Move to EAPI=4, added fix gold linker
02 Mar 2011; Justin Lecher <jlec@gentoo.org> calcoo-1.3.16.ebuild,
calcoo-1.3.18.ebuild:
diff --git a/sci-calculators/calcoo/calcoo-1.3.18.ebuild b/sci-calculators/calcoo/calcoo-1.3.18.ebuild
index ff4f299a2845..72c42ddb4013 100644
--- a/sci-calculators/calcoo/calcoo-1.3.18.ebuild
+++ b/sci-calculators/calcoo/calcoo-1.3.18.ebuild
@@ -1,13 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/calcoo/calcoo-1.3.18.ebuild,v 1.6 2011/03/02 13:26:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/calcoo/calcoo-1.3.18.ebuild,v 1.7 2012/04/26 16:06:35 jlec Exp $
-EAPI="1"
+EAPI=4
-inherit eutils
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
DESCRIPTION="Scientific calculator designed to provide maximum usability"
-HOMEPAGE="http://calcoo.sourceforge.net"
+HOMEPAGE="http://calcoo.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
@@ -19,14 +21,15 @@ RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_compile() {
- econf --disable-gtktest
- emake || die "emake failed."
+PATCHES=( "${FILESDIR}"/${P}-gold.patch )
+
+src_configure() {
+ local myeconfargs=( --disable-gtktest )
+ autotools-utils_src_configure
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog NEWS README
+ autotools-utils_src_install
newicon src/pixmaps/main.xpm ${PN}.xpm
make_desktop_entry ${PN} Calcoo ${PN} "Education;Math"
}
diff --git a/sci-calculators/calcoo/files/calcoo-1.3.18-gold.patch b/sci-calculators/calcoo/files/calcoo-1.3.18-gold.patch
new file mode 100644
index 000000000000..1369dd526b28
--- /dev/null
+++ b/sci-calculators/calcoo/files/calcoo-1.3.18-gold.patch
@@ -0,0 +1,16 @@
+ src/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index b14dc1e..d713b51 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -36,7 +36,7 @@ output.c \
+ texts.h
+
+ INCLUDES = @GTK_CFLAGS@
+-LDADD = @GTK_LIBS@
++LDADD = @GTK_LIBS@ -lm
+ CLEANFILES = *~
+ DISTCLEANFILES = .deps/*.P
+
diff --git a/sci-calculators/calcoo/metadata.xml b/sci-calculators/calcoo/metadata.xml
index b229aec85b8f..d369d068ffb8 100644
--- a/sci-calculators/calcoo/metadata.xml
+++ b/sci-calculators/calcoo/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
+ <herd>sci</herd>
</pkgmetadata>