summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415-r1.ebuild')
-rw-r--r--sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415-r1.ebuild b/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415-r1.ebuild
new file mode 100644
index 000000000000..aadcea514255
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415-r1.ebuild,v 1.1 2013/12/02 11:10:59 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+DESCRIPTION="GUI for MSMS and displaying its results in PyMOL"
+HOMEPAGE="http://www.biotec.tu-dresden.de/~hongboz/msms_pymol/msms_pymol.html"
+SRC_URI="http://www.biotec.tu-dresden.de/~hongboz/msms_pymol/pymol_script/msms_pymol.py -> ${P}.py"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD pymol"
+IUSE=""
+
+RDEPEND="
+ sci-chemistry/msms-bin
+ sci-chemistry/pymol[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ mkdir "${S}" || die
+ cp "${DISTDIR}"/${A} "${S}/" || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-msms.patch
+ sed \
+ -e "s:GENTOOMSMS:${EPREFIX}/opt/bin/msms:g" \
+ -e "s:GENTOOXYZRN:${EPREFIX}/usr/bin/pdb_to_xyzrn:g" \
+ -i ${A} || die
+}
+
+src_install() {
+ python_moduleinto pmg_tk/startup
+ python_parallel_foreach_impl python_domodule ${P}.py
+ python_parallel_foreach_impl python_optimize
+}