summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/vbs')
-rw-r--r--sci-electronics/vbs/ChangeLog25
-rw-r--r--sci-electronics/vbs/Manifest5
-rw-r--r--sci-electronics/vbs/files/digest-vbs-1.4.01
-rw-r--r--sci-electronics/vbs/files/vbs-gcc-3.4.patch44
-rw-r--r--sci-electronics/vbs/metadata.xml8
-rw-r--r--sci-electronics/vbs/vbs-1.4.0.ebuild40
6 files changed, 123 insertions, 0 deletions
diff --git a/sci-electronics/vbs/ChangeLog b/sci-electronics/vbs/ChangeLog
new file mode 100644
index 000000000000..5745fd11f724
--- /dev/null
+++ b/sci-electronics/vbs/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for app-sci/vbs
+# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/vbs/ChangeLog,v 1.1 2004/12/27 20:29:23 ribosome Exp $
+
+*vbs-1.4.0 (27 Dec 2004)
+
+ 27 Dec 2004; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +files/vbs-gcc-3.4.patch, +vbs-1.4.0.ebuild:
+ Moved from app-sci/vbs to sci-electronics/vbs.
+
+ 03 Oct 2004; <plasmaroo@gentoo.org> vbs-1.4.0.ebuild,
+ +files/vbs-gcc-3.4.patch:
+ Patching VBS for gcc-3.4; bug #65613.
+
+ 05 Jun 2004; David Holm <dholm@gentoo.org> vbs-1.4.0.ebuild:
+ Added to ~ppc.
+
+ 19 Apr 2004; Patrick Kursawe <phosphan@gentoo.org> vbs-1.4.0.ebuild:
+ Adding IUSE
+
+*vbs-1.4.0 (30 Nov 2003)
+
+ 30 Nov 2003; <plasmaroo@gentoo.org> vbs-1.4.0.ebuild:
+ Initial commit...
+
diff --git a/sci-electronics/vbs/Manifest b/sci-electronics/vbs/Manifest
new file mode 100644
index 000000000000..ce814f0ba270
--- /dev/null
+++ b/sci-electronics/vbs/Manifest
@@ -0,0 +1,5 @@
+MD5 aeae87ff0bc19aec76cc86824de06b0b ChangeLog 593
+MD5 dfc3be85f642ba592f2c4f5b05a5d998 vbs-1.4.0.ebuild 858
+MD5 e49bb02132d2cd74ad4e6ee291e102d9 metadata.xml 220
+MD5 0afd4a3b8f7839b7a339d2a1f1353bc4 files/vbs-gcc-3.4.patch 1658
+MD5 22a114171374699f394635225aecca7e files/digest-vbs-1.4.0 61
diff --git a/sci-electronics/vbs/files/digest-vbs-1.4.0 b/sci-electronics/vbs/files/digest-vbs-1.4.0
new file mode 100644
index 000000000000..c4a22a0408b9
--- /dev/null
+++ b/sci-electronics/vbs/files/digest-vbs-1.4.0
@@ -0,0 +1 @@
+MD5 07619d3dbfc030639d8ed1271f792d62 vbs-1.4.0.tar.gz 275974
diff --git a/sci-electronics/vbs/files/vbs-gcc-3.4.patch b/sci-electronics/vbs/files/vbs-gcc-3.4.patch
new file mode 100644
index 000000000000..9ee5b1af06fd
--- /dev/null
+++ b/sci-electronics/vbs/files/vbs-gcc-3.4.patch
@@ -0,0 +1,44 @@
+--- src/common/bvector.h 2003-01-12 04:40:59.000000000 +0000
++++ src/common/bvector.h 2004-10-03 18:19:38.364060736 +0100
+@@ -88,10 +88,6 @@
+ position_type _begin; // Starting position.
+ position_type _end; // Stopping position.
+ size_type _size; // Size of this sub-bit vector.
+-
+- // Only bit_vector can create a sub_bit_vector object.
+- sub_bit_vector(bit_vector &, const position_type, const position_type);
+- sub_bit_vector(const sub_bit_vector &);
+ public:
+ sub_bit_vector &operator=(const sub_bit_vector &);
+ sub_bit_vector &operator=(const const_sub_bit_vector &);
+@@ -100,6 +96,10 @@
+ { return _size; }
+ ostream_type &info(ostream_type &) const;
+
++ // Only bit_vector can create a sub_bit_vector object.
++ sub_bit_vector(bit_vector &, const position_type, const position_type);
++ sub_bit_vector(const sub_bit_vector &);
++
+ // We don't need any other method, yet!
+ };
+ class const_sub_bit_vector
+@@ -113,15 +113,15 @@
+ position_type _begin; // Starting position.
+ position_type _end; // Stopping position.
+ size_type _size; // Size of this sub-bit vector.
+-
+- // Only bit_vector can create a sub_bit_vector object.
+- const_sub_bit_vector(const bit_vector &, const position_type, const position_type);
+- const_sub_bit_vector(const const_sub_bit_vector &);
+ public:
+ size_type size() const
+ { return _size; }
+ ostream_type &info(ostream_type &) const;
+
++ // Only bit_vector can create a sub_bit_vector object.
++ const_sub_bit_vector(const bit_vector &, const position_type, const position_type);
++ const_sub_bit_vector(const const_sub_bit_vector &);
++
+ // We don't need any other method, yet!
+ };
+
diff --git a/sci-electronics/vbs/metadata.xml b/sci-electronics/vbs/metadata.xml
new file mode 100644
index 000000000000..e2035cdbb121
--- /dev/null
+++ b/sci-electronics/vbs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>plasmaroo@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-electronics/vbs/vbs-1.4.0.ebuild b/sci-electronics/vbs/vbs-1.4.0.ebuild
new file mode 100644
index 000000000000..e0731cc17693
--- /dev/null
+++ b/sci-electronics/vbs/vbs-1.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation and Tim Yamin <plasmaroo@gentoo.org> <plasmaroo@squirrelsoft.org.uk>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/vbs/vbs-1.4.0.ebuild,v 1.1 2004/12/27 20:29:23 ribosome Exp $
+
+inherit eutils
+
+HOMEPAGE="http://www.geda.seul.org/tools/vbs/index.html"
+DESCRIPTION="vbs - the Verilog Behavioral Simulator"
+SRC_URI="http://www.geda.seul.org/dist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=sys-devel/flex-2.3
+ >=sys-devel/bison-1.22"
+
+src_unpack () {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gcc-3.4.patch
+}
+
+src_compile () {
+ cd src
+ econf || die
+ emake vbs || die
+}
+
+src_install () {
+ dodoc BUGS CONTRIBUTORS COPYRIGHT FAQ README vbs.txt
+
+ docinto examples
+ dodoc EXAMPLES/*
+
+ exeinto /usr/bin
+ doexe src/vbs
+}