summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild')
-rw-r--r--sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild91
1 files changed, 0 insertions, 91 deletions
diff --git a/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild b/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild
deleted file mode 100644
index 09431f36f810..000000000000
--- a/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild,v 1.30 2012/10/19 10:34:40 jlec Exp $
-
-inherit autotools eutils fortran-2 flag-o-matic multilib toolchain-funcs
-
-MyPN="${PN/-reference/}"
-
-DESCRIPTION="FORTRAN reference implementation of LAPACK Linear Algebra PACKage"
-HOMEPAGE="http://www.netlib.org/lapack/index.html"
-SRC_URI="
- http://www.netlib.org/lapack/${MyPN}-lite-${PV}.tgz
- mirror://gentoo/${P}-autotools.patch.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 s390 sparc x86 ~x86-fbsd"
-IUSE="doc"
-
-RDEPEND="
- app-admin/eselect-lapack
- virtual/blas"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/lapack-docs )"
-
-S="${WORKDIR}/${MyPN}-lite-${PV}"
-
-pkg_setup() {
- fortran-2_pkg_setup
- if [[ $(tc-getFC) =~ if ]]; then
- ewarn "Using Intel Fortran at your own risk"
- export LDFLAGS="$(raw-ldflags)"
- export NOOPT_FFLAGS=-O
- fi
- ESELECT_PROF=reference
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${WORKDIR}"/${P}-autotools.patch
- epatch "${FILESDIR}"/${P}-test-fix.patch
- eautoreconf
-
- # set up the testing routines
- sed -e "s:g77:$(tc-getFC):" \
- -e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas):" \
- -e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas):" \
- -e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas):" \
- -e "s:lapack\$(PLAT).a:SRC/.libs/liblapack.a:" \
- make.inc.example > make.inc \
- || die "Failed to set up make.inc"
-}
-
-src_compile() {
- econf \
- --libdir="/usr/$(get_libdir)/lapack/reference" \
- --with-blas="$(pkg-config --libs blas)"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README || die "dodoc failed"
- eselect lapack add $(get_libdir) "${FILESDIR}"/eselect.lapack.reference ${ESELECT_PROF}
-}
-
-src_test() {
- cd "${S}"/TESTING/MATGEN
- emake || die "Failed to create tmglib.a"
- cd "${S}"/TESTING
- emake || die "lapack-reference tests failed."
-}
-
-pkg_postinst() {
- local p=lapack
- local current_lib=$(eselect ${p} show | cut -d' ' -f2)
- if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
- # work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${p} set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF}"
- else
- elog "Current eselected ${p} is ${current_lib}"
- elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
- elog "\t eselect ${p} set ${ESELECT_PROF}"
- fi
-}