summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libtifiles/libtifiles-0.6.1.ebuild')
-rw-r--r--sci-libs/libtifiles/libtifiles-0.6.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/libtifiles/libtifiles-0.6.1.ebuild b/sci-libs/libtifiles/libtifiles-0.6.1.ebuild
new file mode 100644
index 000000000000..0064f1ca1468
--- /dev/null
+++ b/sci-libs/libtifiles/libtifiles-0.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libtifiles/libtifiles-0.6.1.ebuild,v 1.1 2004/12/28 21:20:15 ribosome Exp $
+
+DESCRIPTION="Various TI file formats support for the TiLP calculator linking program"
+HOMEPAGE="http://tilp.info/"
+SRC_URI="mirror://sourceforge/tilp/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="nls"
+
+RDEPEND="dev-libs/libticables
+ virtual/libc
+ nls? sys-devel/gettext"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_compile() {
+ local myconf="$(use_enable nls)"
+ econf ${myconf} || die
+
+ # Install "po" files in ${D} rather than to the root dir.
+ cd ${S}/po
+ sed -i -e 's:prefix = /usr:prefix = $(D)/usr:' Makefile
+ cd ${S}
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D}
+ dodoc AUTHORS ChangeLog LOGO README
+}