summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/frobby/frobby-0.8.2-r1.ebuild')
-rw-r--r--sci-mathematics/frobby/frobby-0.8.2-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild b/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..158ee64922bc
--- /dev/null
+++ b/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild,v 1.1 2010/11/06 17:55:32 tomka Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Frobby is a software system and project for computations with monomial ideals"
+HOMEPAGE="http://www.broune.com/frobby/"
+SRC_URI="http://www.broune.com/frobby/frobby_v${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-libs/gmp[-nocxx]
+ doc? ( virtual/latex-base )"
+RDEPEND="dev-libs/gmp[-nocxx]"
+
+S="${WORKDIR}/frobby_v${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-latex.patch"
+ epatch "${FILESDIR}/${PN}-useless-checks.patch"
+ epatch "${FILESDIR}/${PN}-cflags-no-strip.patch"
+}
+
+src_compile() {
+ emake || die "compile failed"
+ emake library || die "making libfrobby failed"
+ if use doc; then
+ # latex loops don't parallelize well
+ emake -j1 doc || die "failed creating documentation"
+ fi
+}
+
+src_install() {
+ dobin bin/frobby
+ dolib.a bin/libfrobby.a
+ insinto /usr/include
+ doins src/frobby.h
+ dodir /usr/include/"${PN}"
+ insinto /usr/include/"${PN}"
+ doins src/stdinc.h
+ if use doc; then
+ dodoc bin/manual.pdf
+ fi
+}