summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dbus/dbus-1.0.2-r2.ebuild')
-rw-r--r--sys-apps/dbus/dbus-1.0.2-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/dbus/dbus-1.0.2-r2.ebuild b/sys-apps/dbus/dbus-1.0.2-r2.ebuild
index 11c699229d6a..ac6e91998e56 100644
--- a/sys-apps/dbus/dbus-1.0.2-r2.ebuild
+++ b/sys-apps/dbus/dbus-1.0.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.0.2-r2.ebuild,v 1.12 2007/05/13 07:12:30 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.0.2-r2.ebuild,v 1.13 2007/06/05 14:59:09 cardoe Exp $
inherit eutils multilib autotools flag-o-matic
@@ -101,6 +101,12 @@ pkg_preinst() {
}
pkg_postinst() {
+ # ensure we create the machine uuid here for people that don't use the
+ # system bus so it would never get created otherwise
+ if [[ ${ROOT} == "/" ]] ; then
+ /usr/bin/dbus-uuidgen --ensure
+ fi
+
elog "To start the D-Bus system-wide messagebus by default"
elog "you should add it to the default runlevel :"
elog "\`rc-update add dbus default\`"