summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dmapi/dmapi-2.2.8.ebuild')
-rw-r--r--sys-apps/dmapi/dmapi-2.2.8.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/dmapi/dmapi-2.2.8.ebuild b/sys-apps/dmapi/dmapi-2.2.8.ebuild
new file mode 100644
index 000000000000..34d04c2ed487
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-2.2.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-2.2.8.ebuild,v 1.1 2007/05/31 06:03:44 vapier Exp $
+
+inherit eutils toolchain-funcs autotools
+
+MY_P="${PN}_${PV}-1"
+DESCRIPTION="XFS data management API library"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/xfsprogs"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.1-only-symlink-when-needed.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+ eautoconf
+}
+
+src_compile() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf --libexecdir=/usr/$(get_libdir) || die
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-dev || die
+ prepalldocs
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libdm.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libdm.so
+}