summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dog/dog-1.7-r1.ebuild')
-rw-r--r--sys-apps/dog/dog-1.7-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/dog/dog-1.7-r1.ebuild b/sys-apps/dog/dog-1.7-r1.ebuild
new file mode 100644
index 000000000000..5d1c588745b5
--- /dev/null
+++ b/sys-apps/dog/dog-1.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dog/dog-1.7-r1.ebuild,v 1.1 2005/05/13 12:46:31 ka0ttic Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dog is better than cat"
+HOMEPAGE="http://jl.photodex.com/dog/"
+SRC_URI="http://jl.photodex.com/dog/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 ppc-macos sparc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/${P}-check-ctime.diff
+ epatch ${FILESDIR}/${PV}-manpage-touchup.patch
+ sed -i \
+ -e 's/^CFLAGS/#CFLAGS/' \
+ -e "s/gcc/$(tc-getCC)/" \
+ Makefile || die "sed Makefile failed"
+}
+
+src_install() {
+ dobin dog || die
+ doman dog.1
+ dodoc README AUTHORS
+}