summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gentoo-functions/gentoo-functions-0.ebuild')
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.ebuild
new file mode 100644
index 000000000000..cf5a25a27ac1
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.ebuild,v 1.1 2014/03/10 19:47:21 williamh Exp $
+
+EAPI=5
+
+DESCRIPTION="base shell functions required by all gentoo systems"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ dodir /lib/gentoo
+ insinto /lib/gentoo
+ newins "${FILESDIR}"/${P}.sh functions.sh
+}