summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/util-linux/util-linux-2.15.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-2.15.ebuild93
1 files changed, 0 insertions, 93 deletions
diff --git a/sys-apps/util-linux/util-linux-2.15.ebuild b/sys-apps/util-linux/util-linux-2.15.ebuild
deleted file mode 100644
index 64b4939cc0eb..000000000000
--- a/sys-apps/util-linux/util-linux-2.15.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.15.ebuild,v 1.3 2009/05/11 16:36:27 vapier Exp $
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
-inherit eutils
-[[ ${PV} == "9999" ]] && inherit git
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-ng-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
-else
- SRC_URI="mirror://kernel/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2
- loop-aes? ( http://loop-aes.sourceforge.net/updates/util-linux-ng-2.15-20090511.diff.bz2 )"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="crypt loop-aes nls old-linux selinux slang uclibc unicode"
-
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
- >=sys-libs/e2fsprogs-libs-1.41
- selinux? ( sys-libs/libselinux )
- slang? ( sys-libs/slang )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/os-headers"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- cd "${S}"
- ./autogen.sh || die
- else
- unpack ${A}
- cd "${S}"
- #epatch "${FILESDIR}"/${PN}-2.13-uclibc.patch #203711
- epatch "${FILESDIR}"/${P}-cpuid-pic.patch #269001
- use loop-aes && epatch "${WORKDIR}"/util-linux-ng-*.diff
- fi
- use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
-}
-
-src_compile() {
- econf \
- --with-fsprobe=blkid \
- $(use_enable nls) \
- --enable-agetty \
- --enable-cramfs \
- $(use_enable old-linux elvtune) \
- --disable-init \
- --disable-kill \
- --disable-last \
- --disable-mesg \
- --enable-partx \
- --enable-raw \
- --enable-rdev \
- --enable-rename \
- --disable-reset \
- --disable-login-utils \
- --enable-schedutils \
- --disable-wall \
- --enable-write \
- --without-pam \
- $(use unicode || echo --with-ncurses) \
- $(use_with selinux) \
- $(use_with slang) \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS NEWS README* TODO docs/*
-
- if use crypt ; then
- newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
- newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
- fi
-}
-
-pkg_postinst() {
- ewarn "The loop-aes code has been split out of USE=crypt and into USE=loop-aes."
- ewarn "If you need support for it, make sure to update your USE accordingly."
-}