summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/consolekit/files/consolekit-0.4.0-polkit-automagic.patch')
-rw-r--r--sys-auth/consolekit/files/consolekit-0.4.0-polkit-automagic.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-auth/consolekit/files/consolekit-0.4.0-polkit-automagic.patch b/sys-auth/consolekit/files/consolekit-0.4.0-polkit-automagic.patch
new file mode 100644
index 000000000000..d068ca23798d
--- /dev/null
+++ b/sys-auth/consolekit/files/consolekit-0.4.0-polkit-automagic.patch
@@ -0,0 +1,31 @@
+Automagic polkit
+
+---
+--- configure.ac
++++ configure.ac
+@@ -55,10 +55,21 @@
+ gthread-2.0 >= $GLIB_REQUIRED_VERSION
+ )
+
+-PKG_CHECK_MODULES(POLKIT,
+- polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION,
+- have_polkit=yes,
+- have_polkit=no)
++AC_ARG_ENABLE([polkit],
++ AC_HELP_STRING([--enable-polkit], [Enable PolicyKit support (default auto)]),
++ enable_polkit=$enableval,
++ enable_polkit=auto)
++
++if test "x$enable_polkit" != "xno"; then
++ PKG_CHECK_MODULES(POLKIT,
++ polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION,
++ have_polkit=yes,
++ have_polkit=no)
++ if test "x$enable_polkit" = "xyes" -a "x$have_polkit" = "xno"; then
++ AC_MSG_ERROR([PolicyKit support explicitly requested but dependencies not found])
++ fi
++fi
++
+ if test "x$have_polkit" = "xyes" ; then
+ AC_DEFINE(HAVE_POLKIT, [], [Define if we have polkit])
+ fi