summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/torque/files/1.2.0_p1-respect-ldflags.patch')
-rw-r--r--sys-cluster/torque/files/1.2.0_p1-respect-ldflags.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/sys-cluster/torque/files/1.2.0_p1-respect-ldflags.patch b/sys-cluster/torque/files/1.2.0_p1-respect-ldflags.patch
new file mode 100644
index 000000000000..8bdab247646e
--- /dev/null
+++ b/sys-cluster/torque/files/1.2.0_p1-respect-ldflags.patch
@@ -0,0 +1,60 @@
+diff -urN torque-1.2.0p1.orig/src/iff/Makefile.in torque-1.2.0p1/src/iff/Makefile.in
+--- torque-1.2.0p1.orig/src/iff/Makefile.in 2005-02-07 18:57:06.000000000 -0800
++++ torque-1.2.0p1/src/iff/Makefile.in 2005-02-20 00:54:58.444042744 -0800
+@@ -114,7 +114,7 @@
+ $(INSTALL) -m 4755 $(TARGET) $(sbindir)
+
+ pbs_iff: $(OBJS) $(PBS_LIBS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS) $(PBS_LIBS) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJS) $(PBS_LIBS) $(LIBS)
+
+ @mk_cleanup@
+ @mk_tail@
+diff -urN torque-1.2.0p1.orig/src/mom_rcp/Makefile.in torque-1.2.0p1/src/mom_rcp/Makefile.in
+--- torque-1.2.0p1.orig/src/mom_rcp/Makefile.in 2005-02-07 18:57:06.000000000 -0800
++++ torque-1.2.0p1/src/mom_rcp/Makefile.in 2005-02-20 00:55:10.253247472 -0800
+@@ -115,7 +115,7 @@
+ $(INSTALL) -m 4755 $(TARGET) $(sbindir)
+
+ $(TARGET): $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJS) $(LIBS)
+
+
+ # needed for make depend
+diff -urN torque-1.2.0p1.orig/src/scheduler.basl/Makefile.in torque-1.2.0p1/src/scheduler.basl/Makefile.in
+--- torque-1.2.0p1.orig/src/scheduler.basl/Makefile.in 2005-02-07 18:57:07.000000000 -0800
++++ torque-1.2.0p1/src/scheduler.basl/Makefile.in 2005-02-20 01:11:02.760444368 -0800
+@@ -133,7 +133,7 @@
+ $(CC) $(CFLAGS) -o $@ $(OBJS_COMMON) $(OBJS_COMP) $(LIBRARIES)
+
+ pbs_sched: $(OBJS_COMMON) $(OBJS_SCHED)
+- $(CC) $(CFLAGS) -o $@ $(OBJS_COMMON) $(OBJS_SCHED) $(LIBRARIES)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJS_COMMON) $(OBJS_SCHED) $(LIBRARIES)
+
+ pbs_sched.o: $(SCHD_SRC) $(srcdir)/af_system.h $(srcdir)/af_server.h basl2c
+ @if expr $(SCHD_SRC) : '.*\.basl$$' > /dev/null 2>&1; then \
+diff -urN torque-1.2.0p1.orig/src/scheduler.cc/Makefile.in torque-1.2.0p1/src/scheduler.cc/Makefile.in
+--- torque-1.2.0p1.orig/src/scheduler.cc/Makefile.in 2005-02-07 18:57:07.000000000 -0800
++++ torque-1.2.0p1/src/scheduler.cc/Makefile.in 2005-02-20 01:11:17.845151144 -0800
+@@ -127,7 +127,7 @@
+ $(INSTALL) -m 700 $(TARGET) $(sbindir)
+
+ $(TARGET): $(OBJS) $(SCHEDLIB)
+- $(CC) $(CFLAGS) -o $@ $(OBJS) $(SCHEDLIB) $(PBSLIBS) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJS) $(SCHEDLIB) $(PBSLIBS) $(LIBS)
+
+ distclean::
+ -(cd $(SCHD_BUILD) && $(MAKE) $@; exit 0) > /dev/null 2>&1
+diff -urN torque-1.2.0p1.orig/src/scheduler.tcl/Makefile.in torque-1.2.0p1/src/scheduler.tcl/Makefile.in
+--- torque-1.2.0p1.orig/src/scheduler.tcl/Makefile.in 2005-02-07 18:57:07.000000000 -0800
++++ torque-1.2.0p1/src/scheduler.tcl/Makefile.in 2005-02-20 01:11:37.748125432 -0800
+@@ -119,7 +119,7 @@
+ $(INSTALL) -m 700 $(TARGET) $(sbindir)
+
+ $(TARGET): $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS) $(LIBRARIES)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJS) $(LIBRARIES)
+
+ @mk_cleanup@
+ @mk_tail@