summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils/binutils-2.11.92.0.12.3.ebuild')
-rw-r--r--sys-devel/binutils/binutils-2.11.92.0.12.3.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/sys-devel/binutils/binutils-2.11.92.0.12.3.ebuild b/sys-devel/binutils/binutils-2.11.92.0.12.3.ebuild
deleted file mode 100644
index ad737eea2838..000000000000
--- a/sys-devel/binutils/binutils-2.11.92.0.12.3.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: System Team <system@gentoo.org>
-# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.92.0.12.3.ebuild,v 1.1 2001/12/22 05:10:25 drobbins Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Tools necessary to build programs"
-SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2"
-
-DEPEND="virtual/glibc"
-
-src_compile() {
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf} || die
- if [ "`use static`" ]
- then
- emake -e LDFLAGS=-all-static || die
- else
- emake || die
- fi
-}
-
-src_install() {
- make prefix=${D}/usr mandir=${D}/usr/share/man install || die
- #c++filt is included with gcc -- what are these GNU people thinking?
- rm ${D}/usr/bin/c++filt ${D}/usr/share/man/man1/c++filt*
-
- #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip; we should reverse
- #it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- #the strip symlink gets created in the loop below
-
- #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
- #size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
- #and create the appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv $x ../${CHOST}/bin/${x}
- else
- rm -f $x
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
- cd ${S}
- if [ -z "`use build`" ]
- then
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING \
- gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- else
- rm -rf ${D}/usr/share/man
- fi
-
-}
-
-
-