summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils/binutils-2.11.92.0.7.ebuild')
-rw-r--r--sys-devel/binutils/binutils-2.11.92.0.7.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/sys-devel/binutils/binutils-2.11.92.0.7.ebuild b/sys-devel/binutils/binutils-2.11.92.0.7.ebuild
index 123b3d5d5d90..b9d330163a96 100644
--- a/sys-devel/binutils/binutils-2.11.92.0.7.ebuild
+++ b/sys-devel/binutils/binutils-2.11.92.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.92.0.7.ebuild,v 1.11 2003/05/25 15:34:03 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.92.0.7.ebuild,v 1.12 2003/09/06 08:09:19 msterret Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Tools necessary to build programs"
@@ -29,16 +29,16 @@ src_compile() {
src_install() {
make prefix=${D}/usr mandir=${D}/usr/share/man install || die
- #c++filt is included with gcc -- what are these GNU people thinking?
+ #c++filt is included with gcc -- what are these GNU people thinking?
rm ${D}/usr/bin/c++filt ${D}/usr/share/man/man1/c++filt*
-
+
#strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip; we should reverse
#it:
rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
#the strip symlink gets created in the loop below
-
- #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
+
+ #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
#size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
#and create the appropriate symlinks. Things are cleaner that way.
cd ${D}/usr/bin
@@ -48,19 +48,19 @@ src_install() {
if [ ! -e ../${CHOST}/bin/${x} ]
then
mv $x ../${CHOST}/bin/${x}
- else
+ else
rm -f $x
fi
ln -s ../${CHOST}/bin/${x} ${x}
done
cd ${S}
if [ -z "`use build`" ]
- then
+ then
dodoc COPYING* README
docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
docinto gas
dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING \
gas/NEWS gas/README*
@@ -72,10 +72,10 @@ src_install() {
dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
docinto opcodes
dodoc opcodes/ChangeLog*
- else
- rm -rf ${D}/usr/share/man
- fi
-
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+
}