summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/files/3.4.3/libssp.patch51
-rw-r--r--sys-devel/gcc/gcc-3.3.6-r1.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.4.6-r2.ebuild11
-rw-r--r--sys-devel/gcc/gcc-4.0.4.ebuild5
5 files changed, 8 insertions, 69 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 4f8a87bdb717..859623496d8f 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.839 2011/12/06 01:04:08 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.840 2011/12/06 04:05:49 vapier Exp $
+
+ 06 Dec 2011; Mike Frysinger <vapier@gentoo.org> -files/3.4.3/libssp.patch,
+ gcc-3.3.6-r1.ebuild, gcc-3.4.6-r2.ebuild, gcc-4.0.4.ebuild:
+ Drop obsolete/unsupported SSP/PIE code in older gcc versions.
06 Dec 2011; Ryan Hill <dirtyepic@gentoo.org> gcc-4.6.2.ebuild:
Bump to patchset 1.1. Fixes compile issues on arm (bug #366253), and enable
diff --git a/sys-devel/gcc/files/3.4.3/libssp.patch b/sys-devel/gcc/files/3.4.3/libssp.patch
deleted file mode 100644
index 0f9608a18125..000000000000
--- a/sys-devel/gcc/files/3.4.3/libssp.patch
+++ /dev/null
@@ -1,51 +0,0 @@
---- gcc-3.4.3-ssp/gcc/gcc.c 2004-11-14 21:17:58.585438344 -0500
-+++ gcc-3.4.3-ssp-libssp/gcc/gcc.c 2004-11-21 13:28:43.699379520 -0500
-@@ -711,7 +711,17 @@
- static const char *link_gcc_c_sequence_spec = LINK_GCC_C_SEQUENCE_SPEC;
- static const char *asm_spec = ASM_SPEC;
- static const char *asm_final_spec = ASM_FINAL_SPEC;
-+
-+#if defined(_LIBSSP_PROVIDES_SSP_)
-+#if defined(EFAULT_PIE_SSP) || defined(EFAULT_SSP)
-+static const char *link_spec = LINK_SPEC " %{!fno-stack-protector|!fno-stack-protector-all:-lssp %{static: -lc}}";
-+#else
-+static const char *link_spec = LINK_SPEC " %{fstack-protector|fstack-protector-all:-lssp %{static: -lc}}";
-+#endif // defined(EFAULT_PIE_SSP) || defined(EFAULT_SSP)
-+#else
- static const char *link_spec = LINK_SPEC;
-+#endif // defined(_LIBSSP_PROVIDES_SSP_)
-+
- static const char *lib_spec = LIB_SPEC;
- static const char *libgcc_spec = LIBGCC_SPEC;
- static const char *endfile_spec = ENDFILE_SPEC;
-diff -Nru gcc-3.4.3-ssp/gcc/libgcc-std.ver gcc-3.4.3-ssp-libssp/gcc/libgcc-std.ver
---- gcc-3.4.3-ssp/gcc/libgcc-std.ver 2004-11-14 21:18:00.004222656 -0500
-+++ gcc-3.4.3-ssp-libssp/gcc/libgcc-std.ver 2004-11-15 19:22:11.802713352 -0500
-@@ -175,7 +175,7 @@
- _Unwind_SjLj_ForcedUnwind
- _Unwind_SjLj_Resume
-
--%if !defined(_LIBC_PROVIDES_SSP_)
-+%if !defined(_LIBC_PROVIDES_SSP_) && !defined(_LIBSSP_PROVIDES_SSP_)
- # stack smash handler symbols
- __guard
- __stack_smash_handler
-diff -Nru gcc-3.4.3-ssp/gcc/libgcc2.c gcc-3.4.3-ssp-libssp/gcc/libgcc2.c
---- gcc-3.4.3-ssp/gcc/libgcc2.c 2004-11-14 21:18:00.004222656 -0500
-+++ gcc-3.4.3-ssp-libssp/gcc/libgcc2.c 2004-11-15 19:24:58.428382400 -0500
-@@ -1680,7 +1680,7 @@
-
-
- #ifdef L_stack_smash_handler
--#ifndef _LIBC_PROVIDES_SSP_
-+#if !defined(_LIBC_PROVIDES_SSP_) && !defined(_LIBSSP_PROVIDES_SSP_)
- #include <stdio.h>
- #include <string.h>
- #include <fcntl.h>
-@@ -1797,5 +1797,5 @@
- #endif
- _exit (127);
- }
--#endif /* _LIBC_PROVIDES_SSP_ */
-+#endif /* _LIBC_PROVIDES_SSP_ && _LIBSSP_PROVIDES_SSP_ */
- #endif /* L_stack_smash_handler */
diff --git a/sys-devel/gcc/gcc-3.3.6-r1.ebuild b/sys-devel/gcc/gcc-3.3.6-r1.ebuild
index d9542cfdc0d0..492f4eefa092 100644
--- a/sys-devel/gcc/gcc-3.3.6-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.6-r1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6-r1.ebuild,v 1.22 2011/12/04 23:00:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6-r1.ebuild,v 1.23 2011/12/06 04:05:49 vapier Exp $
PATCH_VER="1.7"
UCLIBC_VER="1.0"
-PIE_VER="8.7.8"
-PP_VER="1.0"
HTB_VER="1.00-r2"
inherit toolchain eutils
diff --git a/sys-devel/gcc/gcc-3.4.6-r2.ebuild b/sys-devel/gcc/gcc-3.4.6-r2.ebuild
index ab46a4d7cb7b..252ff9cb24b0 100644
--- a/sys-devel/gcc/gcc-3.4.6-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.4.6-r2.ebuild
@@ -1,14 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.30 2011/12/04 23:00:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.31 2011/12/06 04:05:49 vapier Exp $
PATCH_VER="1.6"
UCLIBC_VER="1.1"
UCLIBC_GCC_VER="3.4.5"
-PIE_VER="8.7.10"
-PIE_GCC_VER="3.4.6"
-PP_VER="1.0"
-PP_GCC_VER="3.4.6"
HTB_VER="1.00.1"
HTB_GCC_VER="3.4.4"
D_VER="0.24"
@@ -35,11 +31,6 @@ src_unpack() {
# misc patches that havent made it into a patch tarball yet
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
- # nothing in the tree provides libssp.so, so nothing will ever trigger this
- # logic, but having the patch in the tree makes life so much easier for me
- # since I dont have to also have an overlay for this.
- want_libssp && epatch "${FILESDIR}"/3.4.3/libssp.patch
-
# Anything useful and objc will require libffi. Seriously. Lets just force
# libffi to install with USE="objc", even though it normally only installs
# if you attempt to build gcj.
diff --git a/sys-devel/gcc/gcc-4.0.4.ebuild b/sys-devel/gcc/gcc-4.0.4.ebuild
index b2e2a34921a2..a9d813a636eb 100644
--- a/sys-devel/gcc/gcc-4.0.4.ebuild
+++ b/sys-devel/gcc/gcc-4.0.4.ebuild
@@ -1,12 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.4.ebuild,v 1.13 2011/12/03 02:36:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.4.ebuild,v 1.14 2011/12/06 04:05:49 vapier Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.0"
-PIE_VER="8.7.8"
-PP_VER=""
-HTB_VER=""
inherit toolchain