summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/cloop/cloop-2.04.ebuild')
-rw-r--r--sys-fs/cloop/cloop-2.04.ebuild23
1 files changed, 3 insertions, 20 deletions
diff --git a/sys-fs/cloop/cloop-2.04.ebuild b/sys-fs/cloop/cloop-2.04.ebuild
index eda5079450b8..cefa65e142d5 100644
--- a/sys-fs/cloop/cloop-2.04.ebuild
+++ b/sys-fs/cloop/cloop-2.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.04.ebuild,v 1.2 2006/11/10 23:54:37 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.04.ebuild,v 1.3 2006/12/07 19:41:51 genstef Exp $
inherit linux-mod eutils
@@ -18,7 +18,7 @@ pkg_setup() {
CONFIG_CHECK="ZLIB_INFLATE"
if kernel_is 2 4
then
- CONFIG_CHECK="${CONFIG_CHECK} ZLIB_DEFLATE"
+ die "kernel 2.4 is not supported"
fi
MODULE_NAMES="cloop(fs:)"
BUILD_TARGETS="all"
@@ -29,7 +29,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd ${S}
- kernel_is 2 4 || sed -i 's:MODULE_PARM(\([^,]*\), "s");:module_param(\1, charp, 0);:' compressed_loop.c
+ sed -i 's:MODULE_PARM(\([^,]*\), "s");:module_param(\1, charp, 0);:' compressed_loop.c
sed -i -e 's:__stringify(KBUILD_MODNAME):"cloop":' compressed_loop.c
}
@@ -41,20 +41,3 @@ src_install() {
doman debian/create_compressed_fs.1 debian/extract_compressed_fs.1
dodoc CHANGELOG README
}
-
-pkg_postinst () {
- if kernel_is 2 4
- then
- einfo "Adding /dev/cloop devices"
- if [ -e /dev/cloop ] ; then
- rm -f /dev/cloop
- fi
- mknod /dev/cloop b 240 0 || die
- if [ -e /dev/cloop1 ] ; then
- rm -f /dev/cloop1
- fi
- mknod /dev/cloop1 b 240 1 || die
- fi
-
- linux-mod_pkg_postinst
-}