summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/db/db-4.0.14-r2.ebuild')
-rw-r--r--sys-libs/db/db-4.0.14-r2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-libs/db/db-4.0.14-r2.ebuild b/sys-libs/db/db-4.0.14-r2.ebuild
index 4a9c32c55961..c0ac23b5e61d 100644
--- a/sys-libs/db/db-4.0.14-r2.ebuild
+++ b/sys-libs/db/db-4.0.14-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14-r2.ebuild,v 1.24 2004/11/30 19:37:20 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14-r2.ebuild,v 1.25 2004/12/16 10:29:20 eradicator Exp $
IUSE="tcltk java doc"
@@ -47,7 +47,7 @@ src_compile() {
|| myconf="${myconf} --disable-java"
use tcltk \
- && myconf="${myconf} --enable-tcl --with-tcl=/usr/lib" \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
if use java && [ -n "${JAVAC}" ]; then
@@ -62,6 +62,7 @@ src_compile() {
--datadir=/usr/share \
--sysconfdir=/etc \
--localstatedir=/var/lib \
+ --libdir=/usr/$(get_libdir) \
--enable-compat185 \
--enable-cxx \
--with-uniquename \
@@ -77,7 +78,7 @@ src_compile() {
src_install () {
- einstall || die
+ einstall libdir="${D}/usr/$(get_libdir)" || die
db_src_install_usrbinslot