summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 93c9ec117b5b..da4247d5604b 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.20 2004/12/07 01:44:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.21 2004/12/07 15:17:38 vapier Exp $
inherit eutils flag-o-matic gcc versionator
@@ -522,7 +522,7 @@ src_unpack() {
# http://sources.redhat.com/ml/libc-alpha/2003-09/msg00100.html
echo 'int main(){}' > ${T}/gcc_eh_test.c
if ! $(tc-getCC) ${T}/gcc_eh_test.c -lgcc_eh 2>/dev/null ; then
- sed -i -e '/static-gnulib := /s:-lgcc -lgcc_eh:-lgcc:' Makeconfig
+ sed -i -e 's:-lgcc_eh::' Makeconfig || die "sed gcc_eh"
fi
# hardened toolchain/relro/nptl/security/etc fixes