summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.6-r5.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r5.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r5.ebuild b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
index 612b53541319..e3378f9e0dd8 100644
--- a/sys-libs/glibc/glibc-2.3.6-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.2 2006/10/04 14:12:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.3 2006/10/06 16:14:30 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -480,9 +480,9 @@ toolchain-glibc_src_install() {
for x in date env ls true uname ; do
x=$(type -p ${x})
[[ -z ${x} ]] && continue
- striptest=$(file -L ${x} 2>/dev/null)
+ striptest=$(LC_ALL="C" file -L ${x} 2>/dev/null)
[[ -z ${striptest} ]] && continue
- [[ ${striptest/statically linked} != "${striptest}" ]] && continue
+ [[ ${striptest} == *"statically linked"* ]] && continue
"${D}"/$(get_libdir)/ld-*.so \
--library-path "${D}"/$(get_libdir) \
${x} > /dev/null \
@@ -540,9 +540,7 @@ toolchain-glibc_pkg_postinst() {
ewarn "Generating all locales; edit /etc/locale.gen to save time/space"
locale_list="${ROOT}usr/share/i18n/SUPPORTED"
fi
- local x jobs
- for x in ${MAKEOPTS} ; do [[ ${x} == -j* ]] && jobs=${x#-j} ; done
- locale-gen -j ${jobs} --config "${locale_list}"
+ locale-gen --config "${locale_list}"
fi
echo