summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/wsmake/ChangeLog8
-rw-r--r--www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch33
-rw-r--r--www-misc/wsmake/wsmake-0.6.4.ebuild8
3 files changed, 43 insertions, 6 deletions
diff --git a/www-misc/wsmake/ChangeLog b/www-misc/wsmake/ChangeLog
index fd96f48d2c19..992e1cf96780 100644
--- a/www-misc/wsmake/ChangeLog
+++ b/www-misc/wsmake/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-misc/wsmake
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/wsmake/ChangeLog,v 1.5 2008/04/21 18:21:48 phreak Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/wsmake/ChangeLog,v 1.6 2009/01/30 01:29:41 dirtyepic Exp $
+
+ 30 Jan 2009; Ryan Hill <dirtyepic@gentoo.org>
+ +files/wsmake-0.6.4-gcc43.patch, wsmake-0.6.4.ebuild:
+ Fix building with GCC-4.3, bug #251745. Patch contributed by mipas.
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch b/www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch
new file mode 100644
index 000000000000..0ecfe62003f5
--- /dev/null
+++ b/www-misc/wsmake/files/wsmake-0.6.4-gcc43.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/show_bug.cgi?id=251745
+https://sourceforge.net/tracker/index.php?func=detail&aid=2520894&group_id=5982&atid=105982
+
+--- libwsmake/wsSubTag.cpp
++++ libwsmake/wsSubTag.cpp.new
+@@ -22,6 +22,7 @@
+ ***********************************************************************/
+ #include <cstdio>
+ #include <cstring>
++#include <cstdlib>
+
+ #include <unistd.h>
+ #ifdef HAVE_SYS_WAIT_H
+--- libwsmake/wsWebPage.cpp
++++ libwsmake/wsWebPage.cpp.new
+@@ -23,6 +23,7 @@
+ #include <cassert>
+ #include <cerrno>
+ #include <ctime>
++#include <cstdlib>
+
+ #include "wsmake.h"
+
+--- libwsmake/wsUtil.cpp
++++ libwsmake/wsUtil.cpp.new
+@@ -28,6 +28,7 @@
+ #include <cassert>
+ #include <cerrno>
+ #include <cstring>
++#include <cstdlib>
+
+ #ifdef HAVE_UTIME_H
+ #include <utime.h>
diff --git a/www-misc/wsmake/wsmake-0.6.4.ebuild b/www-misc/wsmake/wsmake-0.6.4.ebuild
index 4cd48a139e38..996cfd46d926 100644
--- a/www-misc/wsmake/wsmake-0.6.4.ebuild
+++ b/www-misc/wsmake/wsmake-0.6.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/wsmake/wsmake-0.6.4.ebuild,v 1.5 2007/07/15 05:58:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/wsmake/wsmake-0.6.4.ebuild,v 1.6 2009/01/30 01:29:41 dirtyepic Exp $
inherit eutils
@@ -15,8 +15,8 @@ IUSE=""
src_unpack () {
unpack ${A} && cd "${S}"
- #Apply patch to allow compiling
- epatch "${FILESDIR}/${P}-bv.diff" || die "epatch failed."
+ epatch "${FILESDIR}"/${P}-bv.diff
+ epatch "${FILESDIR}"/${P}-gcc43.patch # 251745
}
src_compile () {