summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/gunicorn/gunicorn-0.17.2.ebuild')
-rw-r--r--www-servers/gunicorn/gunicorn-0.17.2.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/www-servers/gunicorn/gunicorn-0.17.2.ebuild b/www-servers/gunicorn/gunicorn-0.17.2.ebuild
deleted file mode 100644
index bbea3aa91410..000000000000
--- a/www-servers/gunicorn/gunicorn-0.17.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-0.17.2.ebuild,v 1.3 2013/03/26 11:42:29 ago Exp $
-
-EAPI="5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.1 *-jython"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils
-
-DESCRIPTION="A WSGI HTTP Server for UNIX"
-HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc test"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-python/setproctitle"
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? ( dev-python/pytest )"
-
-DOCS="README.rst"
-
-src_prepare() {
- # these tests requires an already installed version of gunicorn
- rm tests/test_003-config.py
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- sphinx-build -b html source build || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- use doc && dohtml -r docs/build/
-}