summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog9
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.523
-rw-r--r--www-servers/nginx/files/nginx-r171
-rw-r--r--www-servers/nginx/nginx-0.3.52.ebuild78
4 files changed, 160 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 9c233c110021..78f58d760bfc 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.97 2006/07/01 17:51:56 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.98 2006/07/04 16:58:38 voxus Exp $
+
+*nginx-0.3.52 (04 Jul 2006)
+
+ 04 Jul 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.52.ebuild,
+ +files/nginx-r1, -nginx-0.3.51.ebuild:
+ Version bump, perl installation fixed (as reported by AlexeyK), upgrade
+ routine added to init-script.
*nginx-0.3.51 (01 Jul 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.3.52 b/www-servers/nginx/files/digest-nginx-0.3.52
new file mode 100644
index 000000000000..f6023490341b
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.52
@@ -0,0 +1,3 @@
+MD5 dbc0b6dd52729b8d1beefe78cfba72c6 nginx-0.3.52.tar.gz 405778
+RMD160 dafdfce4824c162a73878850a307bc4ead1e0738 nginx-0.3.52.tar.gz 405778
+SHA256 744bc7eced5bb0ae68d10d0f5c3b99da53a5d0e1a130b16c31bc354f3a454766 nginx-0.3.52.tar.gz 405778
diff --git a/www-servers/nginx/files/nginx-r1 b/www-servers/nginx/files/nginx-r1
new file mode 100644
index 000000000000..ceea5d847dfc
--- /dev/null
+++ b/www-servers/nginx/files/nginx-r1
@@ -0,0 +1,71 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/files/nginx-r1,v 1.1 2006/07/04 16:58:38 voxus Exp $
+
+opts="${opts} upgrade reload configtest"
+
+depend() {
+ need net
+ use dns logger
+}
+
+start() {
+ configtest || return 1
+ ebegin "Starting nginx"
+ start-stop-daemon --start --pidfile /var/run/nginx.pid \
+ --exec /usr/sbin/nginx -- -c /etc/nginx/nginx.conf
+ eend $? "Failed to start nginx"
+}
+
+stop() {
+ configtest || return 1
+ ebegin "Stopping nginx"
+ start-stop-daemon --stop --pidfile /var/run/nginx.pid
+ eend $? "Failed to stop nginx"
+ rm -f /var/run/nginx.pid
+}
+
+reload() {
+ configtest || return 1
+ ebegin "Refreshing nginx' configuration"
+ kill -HUP `cat /var/run/nginx.pid` &>/dev/null
+ eend $? "Failed to reload nginx"
+}
+
+upgrade() {
+ configtest || return 1
+ ebegin "Upgrading nginx"
+
+ einfo "Sending USR2 to old binary"
+ kill -USR2 `cat /var/run/nginx.pid` &>/dev/null
+
+ einfo "Sleeping 3 seconds before pid-files checking"
+ sleep 3
+
+ if [ ! -f /var/run/nginx.pid.oldbin ]; then
+ eerror "File with old pid not found"
+ return 1
+ fi
+
+ if [ ! -f /var/run/nginx.pid ]; then
+ eerror "New binary failed to start"
+ return 1
+ fi
+
+ einfo "Sleeping 3 seconds before WINCH"
+ sleep 3 ; kill -WINCH `cat /var/run/nginx.pid.oldbin`
+
+ einfo "Sending QUIT to old binary"
+ kill -QUIT `cat /var/run/nginx.pid.oldbin`
+
+ einfo "Upgrade completed"
+
+ eend $? "Upgrade failed"
+}
+
+configtest() {
+ ebegin "Checking nginx' configuration"
+ /usr/sbin/nginx -c /etc/nginx/nginx.conf -t
+ eend $? "failed, please correct errors above"
+}
diff --git a/www-servers/nginx/nginx-0.3.52.ebuild b/www-servers/nginx/nginx-0.3.52.ebuild
new file mode 100644
index 000000000000..498900ee3857
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.52.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.52.ebuild,v 1.1 2006/07/04 16:58:38 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}