summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild')
-rw-r--r--x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild b/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..18df66a6daaf
--- /dev/null
+++ b/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild,v 1.1 2010/04/13 20:42:52 elvanor Exp $
+
+EAPI="2"
+
+GCONF_DEBUG="no"
+G2PUNT_LA="yes"
+inherit eutils gnome2
+
+DESCRIPTION="A canvas library based on GTK+-2, Cairo, and Pango"
+HOMEPAGE="http://live.gnome.org/HippoCanvas"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc python"
+
+RDEPEND=">=dev-libs/glib-2.6
+ dev-libs/libcroco
+ >=x11-libs/gtk+-2.6
+ x11-libs/pango
+ python? ( dev-lang/python
+ dev-python/pycairo
+ dev-python/pygtk )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+DOCS="AUTHORS README TODO"
+
+pkg_setup() {
+ G2CONF="$(use_enable python)"
+}
+
+src_prepare() {
+ cd "$S/python"
+ epatch "${FILESDIR}/${PN}-python-override.patch"
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+ rm "${D}/usr/lib/python2.6/site-packages/hippo.la"
+ rm "${D}/usr/lib/libhippocanvas-1.la"
+}