summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog6
-rw-r--r--x11-libs/openmotif/files/digest-openmotif-2.1.30-r41
-rw-r--r--x11-libs/openmotif/openmotif-2.1.30-r4.ebuild101
-rw-r--r--x11-libs/openmotif/openmotif-2.1.30-r5.ebuild5
4 files changed, 9 insertions, 104 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index 90f88318290d..d892b560b10d 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/openmotif
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.56 2004/11/06 15:03:10 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.57 2004/11/17 14:09:37 lanius Exp $
+
+ 17 Nov 2004; <heino@gentoo.org> -openmotif-2.1.30-r4.ebuild,
+ openmotif-2.1.30-r5.ebuild:
+ force MAKEOPTS=-j1; remove old version
06 Nov 2004; <heino@gentoo.org> openmotif-2.1.30-r4.ebuild,
openmotif-2.1.30-r5.ebuild:
diff --git a/x11-libs/openmotif/files/digest-openmotif-2.1.30-r4 b/x11-libs/openmotif/files/digest-openmotif-2.1.30-r4
deleted file mode 100644
index ead704e865e9..000000000000
--- a/x11-libs/openmotif/files/digest-openmotif-2.1.30-r4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 950f0d409e0ce508fa3995790c1106c7 openmotif-2.1.30-4_MLI.src.tar.gz 8645792
diff --git a/x11-libs/openmotif/openmotif-2.1.30-r4.ebuild b/x11-libs/openmotif/openmotif-2.1.30-r4.ebuild
deleted file mode 100644
index d8fc7a0b647a..000000000000
--- a/x11-libs/openmotif/openmotif-2.1.30-r4.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r4.ebuild,v 1.10 2004/11/06 15:03:10 lanius Exp $
-
-inherit eutils
-
-MY_P=${P}-4_MLI.src
-S=${WORKDIR}/motif
-DESCRIPTION="Open Motif (Metrolink Bug Fix Release)"
-SRC_URI="ftp://ftp.metrolink.com/pub/openmotif/2.1.30-4/${MY_P}.tar.gz"
-HOMEPAGE="http://www.openmotif.org/"
-LICENSE="MOTIF"
-KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64 mips"
-IUSE=""
-DEPEND="virtual/libc
- virtual/x11
- >=sys-apps/sed-4"
-
-SLOT="0"
-
-# glibc-2.3.2-r1/gcc-3.2.3 /w `-mcpu=athlon-xp -O2', right-clicking
-# in nedit triggers DPMS monitor standby instead of popping up the
-# context menu. this doesn't happen on my `stable' test partition
-# where everything is compiled i686, nor with most non-essential
-# packages athlon-xp and only motif i686. needs investigation.
-inherit flag-o-matic
-replace-flags "-mcpu=athlon-xp" "-mcpu=i686"
-
-src_unpack() {
- local cfg="${S}/config/cf/site.def"
-
- unpack ${A}
- cd ${S}
- ebegin "adjusting file permissions"
- chmod -R ug+w .
- eend $? || die
-
- ebegin "setting up site.def"
- cp ${FILESDIR}/site.def ${S}/config/cf/ && \
- echo >>$cfg && \
- echo >>$cfg "#undef OptimizedCDebugFlags" && \
- echo >>$cfg "#define OptimizedCDebugFlags ${CFLAGS}" && \
- echo >>$cfg "#undef OptimizedCplusplusDebugFlags" && \
- echo >>$cfg "#define OptimizedCplusplusDebugFlags ${CXXFLAGS}"
- eend $? || die
-
- sed -i -e "s:#define USE_BYACC YES:#undef USE_BYACC:" config/cf/host.def
-
- # move `system.mwmrc' from `lib/X11' to `lib/X11/mwm' (but install into
- # `/etc/X11/mwm')
- ebegin "patching 'clients/mwm/Imakefile' (mwm confdir)"
- LC_ALL="C" sed -i \
- -e 's:\(SpecialObjectRule.*WmResParse\.o.*/lib/X11\)\(.*\):\1/mwm\2:'\
- -e 's:\(InstallNonExecFile.system\.mwmrc,\).*/lib/X11\(.*\):\1/etc/X11/mwm\2:'\
- "${S}/clients/mwm/Imakefile"
- eend $? || die
- #
-
- epatch ${FILESDIR}/${P}-imake-tmpdir.patch
- # compile on gcc 2.9x
- epatch ${FILESDIR}/${P}-imake-ansi.patch
-}
-
-src_compile() {
- mkdir -p imports/x11
- cd imports/x11
- ln -s /usr/X11R6/bin bin
- ln -s /usr/X11R6/include include
- ln -s /usr/X11R6/lib lib
- cd ${S}
- make World || die
-}
-
-src_install() {
- make DESTDIR=${D} VARDIR=${D}/var/X11/ install || die "make install"
- make DESTDIR=${D} install.man || die "make install.man"
-
- # these overlap with X11
- local NOINSTBIN="imake lndir makedepend makeg mergelib mkdirhier xmkmf"
- local NOINSTMAN1="imake lndir makedepend makeg mkdirhier xmkmf"
-
- einfo "Cleaning up X11 stuff"
- rm -fR ${D}/etc
- for nib in ${NOINSTBIN}; do
- f="${D}usr/X11R6/bin/${nib}"; rm "$f" || die "rm $f"
- done
- for nim in ${NOINSTMAN1}; do
- f="${D}usr/X11R6/man/man1/${nim}.1x"; rm "$f" || die "rm $f"
- done
- rm -rf "${D}usr/X11R6/lib/X11" || die "rm config"
- rm -rf "${D}usr/X11R6/lib/bindings" || die "rm bindings"
-
- einfo "Fixing docs"
- dodoc README COPYRIGHT.MOTIF RELEASE RELNOTES
- dodoc BUGREPORT OPENBUGS CLOSEDBUGS
-}
-
-pkg_postinst() {
- ewarn "This might break applications linked against libXm.so.3"
- ewarn "Just rebuild these applications."
-}
diff --git a/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild b/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
index f3e47a461bdc..023449b11dcb 100644
--- a/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
+++ b/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild,v 1.18 2004/11/06 15:03:10 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild,v 1.19 2004/11/17 14:09:37 lanius Exp $
inherit eutils flag-o-matic
@@ -66,6 +66,9 @@ src_compile() {
# packages athlon-xp and only motif i686. needs investigation.
replace-flags "-mcpu=athlon-xp" "-mcpu=i686"
+ # fails to copmile with -jx
+ MAKEOPTS="${MAKEOPTS} -j1"
+
mkdir -p imports/x11
cd imports/x11
ln -s /usr/X11R6/bin bin