summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/grun/grun-0.9.3-r1.ebuild')
-rw-r--r--x11-misc/grun/grun-0.9.3-r1.ebuild44
1 files changed, 14 insertions, 30 deletions
diff --git a/x11-misc/grun/grun-0.9.3-r1.ebuild b/x11-misc/grun/grun-0.9.3-r1.ebuild
index 73ab10e7c80c..028293f5791f 100644
--- a/x11-misc/grun/grun-0.9.3-r1.ebuild
+++ b/x11-misc/grun/grun-0.9.3-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/grun-0.9.3-r1.ebuild,v 1.8 2012/05/05 04:53:41 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/grun/grun-0.9.3-r1.ebuild,v 1.9 2014/09/03 08:23:00 jer Exp $
-EAPI=2
+EAPI=5
inherit eutils
-DESCRIPTION="a GTK+ application launcher with nice features such as a history"
+DESCRIPTION="gRun is a GTK based Run dialog that closely resembles the Windows Run dialog, just like xexec"
HOMEPAGE="http://code.google.com/p/grun/"
SRC_URI="http://grun.googlecode.com/files/${P}.tar.gz"
@@ -14,12 +14,16 @@ SLOT="0"
KEYWORDS="amd64 ppc x86 ~x86-fbsd"
IUSE="nls"
-RDEPEND="dev-libs/glib
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
x11-libs/gtk+:2
- x11-libs/gdk-pixbuf"
-DEPEND="${RDEPEND}
+"
+DEPEND="
+ ${RDEPEND}
virtual/pkgconfig
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+"
src_prepare() {
epatch "${FILESDIR}"/${P}-no_nls.patch
@@ -31,32 +35,12 @@ src_configure() {
econf \
$(use_enable nls) \
--disable-gtktest \
- --enable-testfile \
--enable-associations \
+ --enable-testfile \
--with-default-xterm=${TERM}
}
src_install() {
- einstall || die
+ default
dodoc AUTHORS BUGS ChangeLog NEWS README TODO
}
-
-pkg_postinst() {
- elog "It is recommended to bind grun to a keychain. Fluxbox users can"
- elog "do this by appending e.g. the following line to ~/.fluxbox/keys:"
- elog
- elog "Mod4 r :ExecCommand grun"
- elog
- elog "Then reconfigure Fluxbox (using the menu) and hit <WinKey>-<r>"
- elog
- elog "The default system-wide definition file for associating file"
- elog "extensions with applications is /etc/gassoc, the default"
- elog "system-wide definition file for recognized console"
- elog "applications is /etc/consfile. They can be overridden"
- elog "on a per user basis by ~/.gassoc and ~/.consfile respectively."
- elog
- elog "To change the default terminal application grun uses, adjust the"
- elog "TERM environment variable accordingly and remerge grun, e.g."
- elog
- elog "TERM=Eterm emerge grun"
-}