summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/obconf/obconf-2.0.3.ebuild')
-rw-r--r--x11-misc/obconf/obconf-2.0.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/obconf/obconf-2.0.3.ebuild b/x11-misc/obconf/obconf-2.0.3.ebuild
new file mode 100644
index 000000000000..6eff515c3ebb
--- /dev/null
+++ b/x11-misc/obconf/obconf-2.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/obconf/obconf-2.0.3.ebuild,v 1.1 2008/02/03 08:04:38 omp Exp $
+
+inherit fdo-mime
+
+DESCRIPTION="ObConf is a tool for configuring the Openbox window manager."
+HOMEPAGE="http://icculus.org/openbox/index.php/ObConf:About"
+SRC_URI="http://icculus.org/openbox/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=gnome-base/libglade-2
+ >=x11-libs/gtk+-2
+ x11-libs/startup-notification
+ >=x11-wm/openbox-3.4.2
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}